roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Haslam <simon_has...@yahoo.co.uk>
Subject Re: Roller 4.0 RC9 installation problem on OAS 10.1.3.3.0 (OC4J)
Date Thu, 17 Jan 2008 03:51:02 GMT


Dave Johnson-8 wrote:
> 
> Are there error messages in any other log files? OC4J should have it's
> own log file(s) -- do you see any messages there?  Before Roller inits
> it's logging system, it logs to a file called roller-startup.log...
> 

Firstly: Dave, Gaetano & John thank you for your responses - I do humbly
apologise for not replying sooner as I was only checking
mail-archives.apache.org and didn't notice them on there.

Anyway, I'm having another look at this issue now (I've downloaded 4.0 too).
This is what I've found so far:

* I have a roller-startup.log but this is empty. Possibly it was written to
before I added a line for log4j.appender.roller.File=/temp/roller.log in
roller-custom.properties though it seems to be recreated if I delete it and
restart the container.

* I think the database connection is happening OK - e.g. if you use an
invalid password or the wrong connection syntax you get a different error.
e.g.
DatabaseProvider:errorMessage - ERROR: unable to obtain database connection.
Likely problem: bad connection parameters or database unavailable.
--- ROOT CAUSE ---
java.sql.SQLException: Io exception: Invalid connection string format, a
valid format is: "host:port:sid" 

* I have tried both my original pooled connection and John's "straight"
connection but still get the same "Weblogger startup INCOMPLETE, user
interaction required" error.


Further thoughts:
* I wonder if it's something to do with paths or environment variables -
that sort of thing could be different between Tomcat and OC4J. E.g.
log4j.appender.roller.File=${catalina.base} in roller.properties has to be
overridden.

* I had a bit of a dig in the source: RollerContext.ContextInitialized =>
WebLoggerStartup.prepare() => DatabaseInstaller.CreateDatabase... which has
an info message "Creating Roller Weblogger database tables" which I'm not
seeing so it's not getting that far. I'm also not seeing "Roller Weblogger
startup failed during app preparation" either. 

Simon
-- 
View this message in context: http://www.nabble.com/Roller-4.0-RC9-installation-problem-on-OAS-10.1.3.3.0-%28OC4J%29-tp13714430s12275p14907554.html
Sent from the Roller - User mailing list archive at Nabble.com.


Mime
View raw message