roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Bloom" <yagottabeli...@gmail.com>
Subject Re: Roller 4.0 and Roller Planet Issue
Date Fri, 28 Dec 2007 19:59:48 GMT
I edit the template using the roller ui. l

(login and go to design tab. then you
want to use create a custom theme. then you would edit the template
files using the UI editor.)

On Dec 28, 2007 1:22 PM, Nate Keegan <nate.keegan@cityofprescott.net> wrote:
> Very close here...
>
> I would like to duplicate blogs.sun.com (recent posts, etc)
>
> Here is what I have done:
>
> I created planet-custom.properties in the same directory as my
> roller-custom.properties and here are the contents of that file:
>
> <roller-custom.properties>
> cache.dir=/opt/SUNWappserver/domains/domain1/roller_data/planet/cache
> output.dir=/opt/SUNWappserver/domains/domain1/roller_data/planet/webapp
> template.dir=/opt/SUNWappsserver/domains/domain1/applications/j2ee-modules/roller/WEB-INF/velocity/templates/planet
>
> # Specify database configuration type of 'jndi' or 'jdbc'
> database.configurationType=jdbc
>
> # For database configuration type 'jndi',this will be used
> #database.jndi.name=jdbc/rollerdb
>
> # For database configuration type of 'jdbc', you MUST override these
> database.jdbc.driverClass=com.mysql.jdbc.Driver
> database.jdbc.connectionURL=jdbc:mysql://localhost:3306/rollerdb
> database.jdbc.username=roller
> database.jdbc.password=fooblat
> </roller-custom.properties>
>
> cache.dir and output.dir are pretty arbitrary in terms of their
> location. The template directory may or may not be correct, not sure. It
> is a real directory but I'm not sure what the
>
> I can login to Roller as a global admin and I can access the Planet
> administration page without an error now.
>
> What I am unsure of is the settings I need in order to get Planet
> working properly.
>
> Here is how I have Roller setup:
>
> I created a blog called 'planet' and assigned a theme to it (frontpage
> is not in my list of themes so I am guessing that this is a special theme?)
>
> I edited /path/to/my/themes/frontpage/Weblog.vm and made the following
> change (diff style):
>
> --- Weblog.dist Fri Dec 28 09:06:38 2007
> +++ Weblog.vm   Fri Dec 28 09:07:27 2007
> @@ -34,10 +34,10 @@
>
>                      #if (!$model.results)
>                          ## 1) SITE-WIDE entries (the default)
> -                        #set($pager =
> $site.getWeblogEntriesPager($since, $maxResults))
> +                        ##set($pager =
> $site.getWeblogEntriesPager($since, $maxResults))
>
>                          ## 2) PLANET-entries
> -                        ## set($pager =
> $planet.getAggregationPager($since, $maxResults))
> +                        # set($pager =
> $planet.getAggregationPager($since, $maxResults))
>                          ## The below pager code should work against either:
>
>
> Server Admin  > Configuration
> Handle of weblog to server as frontpage blog is 'planet'
> Enable aggregated site-wide frontpage is checked
> Absolute URL to site is (for me) http://server:port/roller (i.e.
> http://viking:8080/roller for me)
>
> Planet Admin > Configuration
> Assigned a planet title, description, etc
> Absolute URL to Planet page is http://server:port/roller/planet (in my
> case http://viking:8080/roller/planet)
>
> If I go to the front page of Roller I see the regular old planet blog
> but nothing in terms of the aggregation items (am guessing that I need
> to wait for the Planet tasks to update?)
>
> Am I missing any steps?
>

Mime
View raw message