roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Bloom" <yagottabeli...@gmail.com>
Subject Re: Planet setup bootstrap issue with roller 4.0 rc3
Date Sun, 09 Dec 2007 20:50:09 GMT
 # set ($pager =$planet.getAggregationPager($since, $maxResults))

is correct notation.

I had  #  set($pager =$planet.getAggregationPager($since, $maxResults))

with a space after # which causes it to not parse it correctly.


On Dec 9, 2007 7:43 AM, David Bloom <yagottabelieve@gmail.com> wrote:
> ok, I get past that link now.
>
> I set up a blog which i called aggregator which I give a theme of
> roller front page...
>
> My weblog template now has
>
>                          ## 1) SITE-WIDE entries (the default)
>                         ##set($pager =
> $site.getWeblogEntriesPager($since, $maxResults))
>
>                         ## 2) PLANET-entries
>                         # set($pager =
> $planet.getAggregationPager($since, $maxResults))
>                         ## The below pager code should work against either:
>
> now when i go to http://localhost:8080/roller/
>
> I see under recent entries in the html that is displayed:
>
> # set($pager = org.apache.roller.weblogger.ui.rendering.pagers.PlanetEntriesPager@169084f)
>
>
> On Dec 8, 2007 11:41 PM, Finbar Dineen <elevenit@gmail.com> wrote:
> > @david
> >
> > I had this problem and followed the advice Dave gave in a reply a couple
> > of days ago:
> >
> > "Create a planet-custom.properties file in the same directory as your
> > roller-custom.properties file. Copy the very same database connection
> > parameters that are in your roller-custom.properties file into
> > planet-custom.properties."
> >
> > This solved it for me. I was installing the full release announced this
> > week for a new client (soon to be visible at antiB.ullying.com). I'll be
> > updating my other installations now I know this is working fine.
> >
> > Dave, great work.
> >
> > Finbar Dineen
> > http://www.limlom.com/
> >
> > David Bloom írta:
> >
> > > click on Planet administration link on main menu-
> > > http://localhost:8080/roller/roller-ui/admin/planetConfig.rol
> > >
> > > ERROR 2007-12-08 20:02:43,078 StandardWrapperValve:invoke -
> > > Servlet.service() for servlet default threw exception
> > > java.lang.IllegalStateException: Roller Planet has not been
> > > bootstrapped yeti had this in my
> > >
> > > C:\Java5\apache-tomcat-5.5.25\common\classes  roller custom file
> > >
> > > planet.aggregator.enabled=true
> > > planet.aggregator.cache.dir=C:\\Java5\\apache-tomcat-5.5.25\\work\\cache
> > > tasks.enabled=ScheduledEntriesTask,ResetHitCountsTask,\
> > > TurnoverReferersTask,PinqQueueTask,RefreshPlanetRollerTask,SyncWebsitesTask
> > > rendering.siteModels=\
> > > org.apache.roller.weblogger.ui.rendering.model.SiteModel,\
> > > org.apache.roller.weblogger.ui.rendering.model.PlanetModel
> >
>

Mime
View raw message