roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: Unable to get Roller 4.0 RC8 working on Resin 3.0
Date Mon, 05 Nov 2007 15:29:01 GMT
I haven't touched Resin in years, but this error message:

"com.google.inject.ProvisionException: Error while locating instance
 bound to org.apache.roller.weblogger.business.jpa.JPAPersistenceStrategy"

seems to indicate that the Roller classes or some dependencies of the
Roller classes are not on the classpath. You sure all of Roller's
WEB-INF/lib jars are being included on the classpath?

- Dave


On 11/1/07, Chris Hoefgen <choefgen@bstage.ca> wrote:
> I have been trying for the last 2 days to get Roller to run on Resin 3.0.
> No matter how I configure the app I always get the same exception stack
> trace (see below).   I have tried configuring the database both in the
> roller-custom.properties files and as a jndi resource but in either case the
> same thing happens.  Does anyone have any ideas as to what I can try next?
>
> Roller Version:  4.0 rc8
> Resin Version: 3.0.21
> Java Version:  Sun JDK 5.0.
> OS:  Windows XP Pro
>
>
> com.google.inject.ProvisionException: Error while locating instance
>   bound to org.apache.roller.weblogger.business.jpa.JPAPersistenceStrategy
>   for member at
> org.apache.roller.weblogger.business.jpa.JPAWebloggerImpl.<init>(JPAWeblogge
> rImpl.java:77)
>         at

Mime
View raw message