roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guy Katz" <gk...@allot.com>
Subject RE: cache problem/question
Date Tue, 16 Oct 2007 05:30:53 GMT
thanks;
the plugin invalidating the cache is a good solution for me.
so i guess this done programatically? can you point me in the direction of which class to
look in the API?

________________________________

From: Dave [mailto:snoopdave@gmail.com]
Sent: Tue 10/16/2007 3:47 AM
To: user@roller.apache.org
Subject: Re: cache problem/question



On 10/14/07, Guy Katz <gkatz@allot.com> wrote:
> Hi all;
> I added a model plug-in to display some info in my custom theme and in
> the front page.
> This model is updated periodically every 3 minutes. I have noticed that
> the caching of the web pages prevents the updated data from being
> displayed and only cache data is displayed.
> Of course, if I clean the cache using the blog admin the updated data is
> displayed.
>
> What are my options here? I want to see the updated data from this
> plugin at all times. Is there some way to configure the cache for that?
> Any other suggestions?

Let's see... Here are a couple of ideas. You could use an expiring
page cache set to time out every 5, 10 or more minutes -- the longer
the better in terms of site performance. Or you could set the plugin
up to invalidate the cache every time an update results in a
meaningful change.

- Dave



Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message