roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fp <Frank.Pien...@impaqgroup.com>
Subject Re: Cannot login after register
Date Mon, 01 Oct 2007 17:11:03 GMT

thank you dave.
I changed my locale from de_DE to en, but it doesn't help
It was a new, fresh install,
but roller.log reports UpgradeDatabase:upgradeDatabase - New installation
found, setting db version to 311???

Dave Johnson-8 wrote:
> 
> On 10/1/07, fp <Frank.Pientka@impaqgroup.com> wrote:
>> After some strugelling i get Roller 3.1.1 running with WAS 6.0.2.21, JDK
>> 142_SR8, DERBY 10.1.3.2, Hibernate 3.1.3.
>> dstest.jsp: SUCCESS: Got datasource and connection, class is
>> com.ibm.ws.rsadapter.jdbc.WSJdbcDataSource
>>
>> But after successfully Registration, I can't login, because the
>> login-redirect.jsp bypasses to yourWebsites.do withaut showing the
>> login-Mask.
>> Also the Exceptions don't help
> 
> Yes, sometimes truly unexpected exceptions occur. For best results you
> should run Roller on Tomcat, Glassfish or Sun Java Web Server, that's
> where all the testing was done ;O)
> 
> 
>> java.lang.NullPointerException at
>>org.apache.roller.ui.core.struts.actions.CreateWebsiteAction.create(CreateWebsiteAction.java:104)
> 
> That exception seems to indicate that your user has a null locale
> field. I'm not sure how that  would happen. Are you doing an upgrade
> or a new install?
> 
> You can probably fix the problem by using SQL to set the user's locale
> field to 'en' or whatever is appropriate for your locale.
> 
> - Dave
> 
> 

-- 
View this message in context: http://www.nabble.com/Cannot-login-after-register-tf4549439s12275.html#a12983329
Sent from the Roller - User mailing list archive at Nabble.com.


Mime
View raw message