roller-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Walter Hardy" <wal...@whardy.com>
Subject RE: Roller install on Sun Web Server 7
Date Thu, 06 Sep 2007 23:20:29 GMT
I made some progress by fixing a jdbc reference in server.xml. It's running
at http://portal.whardy.com/blogs/

However, if I go to create a new user, a blank message is returned in the
status bar up top, and I don't see the user in the Derby DB. Trying to log
in with that user gets me a 404 error page from the roller app. Am I still
looking at DB connection issues? No logs are being generated by the app
server.

Thanks.

-----Original Message-----
From: mraible@gmail.com [mailto:mraible@gmail.com] On Behalf Of Matt Raible
Sent: Wednesday, September 05, 2007 5:57 PM
To: user@roller.apache.org
Subject: Re: Roller install on Sun Web Server 7

Are there any issues with running Spring on Sun Java System Web Server
7 (that's a mouthful)?

Matt

On 9/5/07, Walter Hardy <walter@whardy.com> wrote:
> Hi,
>
> I'm trying to install Roller on Sun Java System Web Server 7 on Solaris
10.
> The reason for this is that I'm trying to create a blog portlet with the
Sun
> Portal Server which deploys on Web Server 7. I've configured the databases
> in Derby and added the JDBC resource.
>
>
>
> I get the following error during the web server startup for the Roller
app:
>
>
>
> WebModule[/blogs]PWC1270: Exception starting filter securityFilter
>
>
>
> java.lang.IllegalStateException: No WebApplicationContext found: no
> ContextLoaderListener registered? at
>
org.springframework.web.context.support.WebApplicationContextUtils.getRequir
> edWebApplicationContext(WebApplicationContextUtils.java:84) at
>
org.acegisecurity.util.FilterToBeanProxy.getContext(FilterToBeanProxy.java:1
> 77) at
>
org.acegisecurity.util.FilterToBeanProxy.doInit(FilterToBeanProxy.java:119)
> at
org.acegisecurity.util.FilterToBeanProxy.init(FilterToBeanProxy.java:189)
> at
>
org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilter
> Config.java:229) at
>
org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(ApplicationFil
> terConfig.java:318) at
>
org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterCon
> fig.java:83) at
>
org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:40
> 42) at
> org.apache.catalina.core.StandardContext.start(StandardContext.java:4702)
at
> com.sun.webserver.connector.nsapi.WebModule.start(WebModule.java:170) at
> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1089) at
> org.apache.catalina.core.StandardHost.start(StandardHost.java:838) at
> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1089) at
> org.apache.catalina.core.StandardEngine.start(StandardEngine.java:514) at
> org.apache.catalina.startup.Embedded.start(Embedded.java:917) at
> com.sun.enterprise.web.PwcWebContainer.onStartup(PwcWebContainer.java:47)
at
>
com.sun.webserver.connector.nsapi.WebContainer.start(WebContainer.java:464)
> at com.sun.webserver.init.J2EERunner.confPostInit(J2EERunner.java:292)
>
>
>
> This error also follows:
>
>
>
>             Null component
>
com.sun.web-1:type=JspMonitor,name=jsp,WebModule=//portal.whardy.com/blogs,J
> 2EEApplication=none,J2EEServer=none
>
>
>
> Are there any suggestions? Thanks.
>
>
> Walter
>
>


-- 
http://raibledesigns.com



Mime
View raw message