roller-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From javaguy44 <javagu...@yahoo.com>
Subject Transport.send problem via properties (with fix)
Date Sun, 30 May 2010 22:19:14 GMT

Hi,

I ran into the Transport.send problems as listed here:
http://old.nabble.com/forum/Search.jtp?forum=12275&local=y&query=transport.send
http://old.nabble.com/email-setup--tp16502139s12275p16502139.html
http://old.nabble.com/Problems-setting-up-mail-(Tomcat)-to20984951s12275.html#a20984951

However, the solutions provided their assume that the user is setting mail
properties via tomcat configuration + JNDI.

I still want to configure my mail.properties via roller-custom.properties

The fix / issue is as follows:
https://svn.apache.org/repos/asf/roller/tags/roller_4.0.1/apps/weblogger/src/java/org/apache/roller/weblogger/util/MailUtil.java

line 652

change from transport.send() to Transport.sendMessage
 - both send(), sendMessage are static methods
 - send() does not use existing connection in MailProvider
 - sendMessage() does!

I tried to post to issue tracker, but it returns 404 at this time

since its a one line change, was hoping someone would just change it for me
instead of me going through the hassle of getting commit rights etc.

Thx
-- 
View this message in context: http://old.nabble.com/Transport.send-problem-via-properties-%28with-fix%29-tp28725261s12275p28725261.html
Sent from the Roller - Dev mailing list archive at Nabble.com.


Mime
View raw message