roller-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg.Hu...@ricoh.co.uk
Subject Re: Eclipse Setup Run As .. Maven install
Date Wed, 03 Feb 2010 14:14:23 GMT
Dave,

I added this,

<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-site-plugin</artifactId>
  <version>2.1</version>
</plugin>

now its looking for

http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-site-plugin/2.1/maven-site-plugin-2.1.pom

which I can http to.

Would you know if there are any settings for a proxy within maven, or does 
it use the workbench settings?



Cheers Greg





Dave <snoopdave@gmail.com> 
03/02/2010 13:53
Please respond to
dev@roller.apache.org


To
dev@roller.apache.org
cc

Subject
Re: Eclipse Setup Run As .. Maven install






Hmm... I can reproduce this problem.


On Wed, Feb 3, 2010 at 7:06 AM,  <Greg.Huber@ricoh.co.uk> wrote:
> Seems to be missing from :
> 
http://people.apache.org/~snoopdave/repo//org/apache/maven/plugins/maven-site-plugin/2.0-beta-6/maven-site-plugin-2.0-beta-6.pom



That module (Maven Site Plugin) should be available from one of the
maven sites (below).


> url = http://repo1.maven.org/maven2
> Downloading:
> 
http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-site-plugin/2.0-beta-6/maven-site-plugin-2.0-beta-6.pom

> url = http://mirrors.ibiblio.org/pub/mirrors/maven2
> Downloading:
> 
http://mirrors.ibiblio.org/pub/mirrors/maven2/org/apache/maven/plugins/maven-site-plugin/2.0-beta-6/maven-site-plugin-2.0-beta-6.pom



But for some reason it is not found and Maven keeps on looking. It
finally stops at the last repo on the list:


> url = http://people.apache.org/~snoopdave/repo/
> Downloading:
> 
http://people.apache.org/~snoopdave/repo//org/apache/maven/plugins/maven-site-plugin/2.0-beta-6/maven-site-plugin-2.0-beta-6.pom

> [ERROR]

I wonder if this is a mirror problem. Could Greg be hitting a UK
version of one of the Maven repos and that repo does not have the
latest Maven Site Plugin?

Another idea: why are we using Maven Site Plugin 2.0-beta-6? Maybe I
should switch to a release version of that module.

- Dave


Share our environment commitment - conserve resources and contribute to the reduction of CO2
emissions by not printing the email unless absolutely necessary to do so. 

Any opinions expressed are those of the author, not Ricoh UK Ltd. This communication does
not constitute either offer or acceptance of any contractually binding agreement. Such offer
or acceptance must be communicated in writing. It is the responsibility of the recipient to
ensure this email and attachments are free from computer viruses before use and the sender
accepts no responsibility or liability for any such computer viruses. 

Ricoh UK Ltd. may monitor the content of emails sent and received via its network for the
purpose of ensuring compliance with its policies and procedures. This communication contains
information, which may be confidential or privileged. The information is intended solely for
the use of the individual or entity named above. If you are not the intended recipient, be
aware that any disclosure, copying, distribution or use of the contents of this information
is prohibited. If you have received this communication in error, please notify the sender
immediately by return email with a copy to  postmaster@ricoh.co.uk . Please contact us on
+44 (0) 208 261 4000 if you need assistance. 

Registered in England No: 473236 
VAT No: GB524161280  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message