roller-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <>
Subject Re: Build, menu and media problems in trunk
Date Sun, 21 Feb 2010 13:52:11 GMT
HI Harald,

Thanks for the helpful problem reports. I committed a fix this morning
that moves those resources that you found from main/java and into
main/resources. I also fixed the directory location problem for

Media File Management should be working 100% (except for the bugs
listed in JIRA) and the problem that you mention must be a regression
caused by some of my work and possibly due to the new build process.
I'll look into this problem next.

- Dave

On Sun, Feb 21, 2010 at 5:55 AM, Harald Wellmann <> wrote:
> I was curious to have a look at the new features in Roller 5.0 compared to
> 4.0.1, so I checked out from trunk (r912111) and gave it a try.
> I used the Maven build, unpacked the binary assembly into my Tomcat 6. The
> build worked without problems and I could start Roller, but the menu tabs on
> the "Create Entry" were missing.
> The reason is that the resources from the weblogger-web module do not get
> copied and packaged.
> Some XML resources are stored in src/main/java and should be moved to
> src/main/resources. As a workaround, I simply told Maven to pick them up
> from the source folder by adding the following to the POM:
>             <resource>
>                <directory>src/main/java</directory>
>                <filtering>false</filtering>
>                <excludes>
>                  <exclude>**/*.java</exclude>
>                </excludes>
>            </resource>
> There is another build issue that Maven did not complain about, but Eclipse
> did when I loaded the project into a workspace:
> The source file for org.apache.roller.weblogger.WebloggerException is stored
> in weblogger-business/src/main/java/org/, it should be moved to
> weblogger-business/src/main/java/org/apache/roller/weblogger.
> Finally, what is the status of media file management? Is this sort of
> complete and only currently broken or are there major gaps?
> At any rate, it does not seem to work at the moment.
> MediaFileImageChooser.jsp has missing closing braces on
> %{#mediaFile.permalink} and %{#mediaFile.thumbnailURL}. Unfortunately, after
> adding the braces, things are still broken.
> The Media File Chooser displays a box with an image name, but no image
> thumbnail. After choosing an image, the URL inserted into the weblog entry
> is incorrect:
> http://localhost:8080/roller/http://localhost:8080/roller/myblog/mediaresource/uuid
> Regards,
> Harald

View raw message