roller-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave <snoopd...@gmail.com>
Subject Re: Problems building and deploying 4.0 on WAS 6.1
Date Wed, 12 Nov 2008 04:02:31 GMT
On Tue, Nov 11, 2008 at 8:20 PM, Kristoffer Larsson <webb@kristoffer.nu> wrote:
> I am trying to deploy Roller 4.0 on WAS 6.1.0.19 and am running into
> problems. For example this:
> http://www.nabble.com/Roller-and-WAS-6.1.0.15-td17366733s12275.html
>
> So I downloaded the source code from here:
> http://roller.apache.org/download.cgi
> Then I followed this guide:
> http://cwiki.apache.org/confluence/display/ROLLER/Build+Guide
>
> The build went successful (after adding mail.jar to some directory), and
> then I created a WAR file and deployed it to the server. Now I get this
> annoying stacktrace when trying to start the application. What am I doing
> wrong here? Any help greatly appreciated!

The error below appears to be caused by a Java version mismatch.
That's the only clue I see.

Roller 4.0 is compiled with JDK 1.5. Perhaps you are running WebSphere
under JDK 1.4.2?

- Dave


> [2008-11-12 02:17:49:310 CET] 00000015 WebGroup      A   SRVE0169I: Loading
> Web Module: Roller Weblogger.
>
> [2008-11-12 02:17:49:341 CET] 00000015 WebApp        E   [Servlet
> Error]-[Failed to load listener:
> org.apache.roller.weblogger.ui.core.RollerSession]: java.lang.LinkageError:
> LinkageError while defining class:
> org.apache.roller.weblogger.ui.core.RollerSession
>
> Could not be defined due to:
> (org/apache/roller/weblogger/ui/core/RollerSession) bad major version at
> offset=6

Mime
View raw message