roller-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glen Mazza (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (ROL-1974) Roller's ROME Propono dependency needs updating to use newer JARs
Date Mon, 25 Aug 2014 18:06:58 GMT

     [ https://issues.apache.org/jira/browse/ROL-1974?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Glen Mazza closed ROL-1974.
---------------------------


> Roller's ROME Propono dependency needs updating to use newer JARs
> -----------------------------------------------------------------
>
>                 Key: ROL-1974
>                 URL: https://issues.apache.org/jira/browse/ROL-1974
>             Project: Apache Roller
>          Issue Type: Bug
>    Affects Versions: 5.1
>            Reporter: Glen Mazza
>            Assignee: David Johnson
>            Priority: Minor
>             Fix For: 5.1
>
>
> mvn clean install of roller trunk reports these POM errors:
> Downloading: http://repo.maven.apache.org/maven2/net/oauth/core/oauth/20090531/oauth-20090531.pom
> [WARNING] The POM for net.oauth.core:oauth:jar:20090531 is missing, no dependency information
available
> Downloading: http://repo.maven.apache.org/maven2/net/oauth/core/oauth-provider/20090531/oauth-provider-20090531.pom
> [WARNING] The POM for net.oauth.core:oauth-provider:jar:20090531 is missing, no dependency
information available
> These 20090531 dependencies are not declared in the Roller POM but referenced by Roller's
Propono dependency.  Roller explicitly lists the 20100527 version of the above JARs instead
to override the 2009 ones.  Upgrading Propono to the new 20100527 versions should cause the
above error message to go away, also the Roller team would no longer need to explicitly list
the 2010 version in its POM.
> Likewise, upgrading Propono to use the latest versions of xmlrpc-common, xmlrpc-client,
and ws-commons-util that Roller presently declares will allow for removal of these three dependencies
from our POM as well as allow us to remove the exclusions for these dependencies under Roller's
Propono dependency: http://svn.apache.org/viewvc/roller/trunk/app/pom.xml?revision=1523514&view=markup#l188.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message