roller-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From snoopd...@apache.org
Subject svn commit: r1491083 - in /roller/trunk: ./ roller-core/ test-utils/ test-utils/src/main/java/org/apache/roller/util/ test-utils/src/main/java/org/apache/roller/weblogger/ant/
Date Sat, 08 Jun 2013 22:17:42 GMT
Author: snoopdave
Date: Sat Jun  8 22:17:42 2013
New Revision: 1491083

URL: http://svn.apache.org/r1491083
Log:
Merging in roller_fewer_modules

Added:
    roller/trunk/test-utils/src/main/java/org/apache/roller/util/
      - copied from r1491055, roller/branches/fewer_modules/test-utils/src/main/java/org/apache/roller/util/
    roller/trunk/test-utils/src/main/java/org/apache/roller/util/SQLScriptRunner.java
      - copied unchanged from r1491055, roller/branches/fewer_modules/test-utils/src/main/java/org/apache/roller/util/SQLScriptRunner.java
Removed:
    roller/trunk/roller-core/
Modified:
    roller/trunk/pom.xml
    roller/trunk/test-utils/pom.xml
    roller/trunk/test-utils/src/main/java/org/apache/roller/weblogger/ant/   (props changed)

Modified: roller/trunk/pom.xml
URL: http://svn.apache.org/viewvc/roller/trunk/pom.xml?rev=1491083&r1=1491082&r2=1491083&view=diff
==============================================================================
--- roller/trunk/pom.xml (original)
+++ roller/trunk/pom.xml Sat Jun  8 22:17:42 2013
@@ -3,14 +3,12 @@
          xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
 
     <modelVersion>4.0.0</modelVersion>
-
     <groupId>org.apache.roller</groupId>
     <artifactId>roller-project</artifactId>
-
     <version>5.1.0-SNAPSHOT</version>
     <packaging>pom</packaging>
 
-    <name>Roller Project - Trunk</name>
+    <name>roller-project</name>
     <description>
         Roller is an open source blog server built with open source Java
         libraries including Apache OpenJPA, Struts2, Velocity and Commons.
@@ -29,418 +27,11 @@
         <roller.version>5.1.0-SNAPSHOT</roller.version>
         <!-- avoid CLOB/BLOB error in all later versions of Derby -->
         <derby.version>10.1.3.1</derby.version>
-        <openjpa.version>2.2.2</openjpa.version>
     </properties>
 
     <modules>
-        <module>roller-core</module>
         <module>test-utils</module>
-        <module>planet-business</module>
-        <module>weblogger-business</module>
-        <module>weblogger-web</module>
         <module>weblogger-webapp</module>
     </modules>
 
-    <build>
-        <defaultGoal>install</defaultGoal>
-
-        <pluginManagement>
-            <plugins>
-
-                <plugin>
-                    <groupId>org.apache.maven.plugins</groupId>
-                    <artifactId>maven-compiler-plugin</artifactId>
-                    <version>2.0.2</version>
-                    <configuration>
-                        <source>1.5</source>
-                        <target>1.5</target>
-                        <fork>true</fork>
-                        <encoding>${project.build.sourceEncoding}</encoding>
-                    </configuration>
-                </plugin>
-
-                <plugin>
-                    <groupId>org.apache.maven.plugins</groupId>
-                    <artifactId>maven-surefire-plugin</artifactId>
-                    <version>2.4.3</version>
-                </plugin>
-
-                <plugin>
-                    <groupId>org.apache.maven.plugins</groupId>
-                    <artifactId>maven-antrun-plugin</artifactId>
-                    <version>1.2</version>
-                </plugin>
-
-                <plugin>
-                    <groupId>org.apache.maven.plugins</groupId>
-                    <artifactId>maven-resources-plugin</artifactId>
-                    <version>2.4.1</version>
-                </plugin>
-
-                <!-- Allow for standalone Tomcat deployment 
-                     using mvn tomcat7:redeploy (See
-                     http://www.jroller.com/gmazza/entry/web_service_tutorial#maventomcat
-                     for necessary config info)
-                -->
-                <plugin>
-                    <groupId>org.apache.tomcat.maven</groupId>
-                    <artifactId>tomcat7-maven-plugin</artifactId>
-                    <version>2.1</version>
-                    <configuration>
-                        <server>myTomcat</server>
-                        <path>/${project.build.finalName}</path>
-                    </configuration>
-                </plugin>
-
-            </plugins>
-
-        </pluginManagement>
-    </build>
-
-    <repositories>
-
-        <repository>
-            <id>central</id>
-            <name>Maven Repository Switchboard</name>
-            <layout>default</layout>
-            <url>http://repo1.maven.org/maven2</url>
-            <snapshots>
-                <enabled>false</enabled>
-            </snapshots>
-        </repository>
-
-        <repository>
-            <id>oauth</id>
-            <url>http://oauth.googlecode.com/svn/code/maven</url>
-        </repository>
-
-        <repository>
-            <id>oss.sonatype.org</id>
-            <url>http://oss.sonatype.org/content/groups/public</url>
-        </repository>
-
-        <!-- for jstl-1.2 for now.. -->
-        <repository>
-            <id>java.net</id>
-            <url>http://download.java.net/maven/2/</url>
-        </repository>
-
-    </repositories>
-
-    <dependencyManagement>
-        <dependencies>
-
-            <!-- core deps -->
-
-            <dependency>
-                <groupId>log4j</groupId>
-                <artifactId>log4j</artifactId>
-                <version>1.2.16</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-collections</groupId>
-                <artifactId>commons-collections</artifactId>
-                <version>3.2.1</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-lang</groupId>
-                <artifactId>commons-lang</artifactId>
-                <version>2.4</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-logging</groupId>
-                <artifactId>commons-logging</artifactId>
-                <version>1.1.3</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-codec</groupId>
-                <artifactId>commons-codec</artifactId>
-                <version>1.4</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>com.google.inject</groupId>
-                <artifactId>guice</artifactId>
-                <version>2.0</version>
-            </dependency>
-
-            <!-- business deps -->
-
-            <dependency>
-                <groupId>org.apache.lucene</groupId>
-                <artifactId>lucene-core</artifactId>
-                <version>4.2.1</version>
-            </dependency>
-            
-            <dependency>
-                <groupId>org.apache.lucene</groupId>
-                <artifactId>lucene-queryparser</artifactId>
-                <version>4.2.1</version>
-            </dependency>
-            
-            <dependency>
-                <groupId>org.apache.lucene</groupId>
-                <artifactId>lucene-analyzers-common</artifactId>
-                <version>4.2.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>net.java.dev.rome</groupId>
-                <artifactId>rome</artifactId>
-                <version>1.0.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>net.java.dev.rome</groupId>
-                <artifactId>rome-fetcher</artifactId>
-                <version>1.0.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>net.java.dev.rome</groupId>
-                <artifactId>rome-propono</artifactId>
-                <version>1.0.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>jdom</groupId>
-                <artifactId>jdom</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>net.oauth.core</groupId>
-                <artifactId>oauth</artifactId>
-                <version>20090531</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>net.oauth.core</groupId>
-                <artifactId>oauth-provider</artifactId>
-                <version>20090531</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <!-- web deps -->
-
-            <dependency>
-                <groupId>commons-fileupload</groupId>
-                <artifactId>commons-fileupload</artifactId>
-                <version>1.1</version>
-                <scope>compile</scope>
-            </dependency>
-
-
-            <dependency>
-                <groupId>org.apache.struts</groupId>
-                <artifactId>struts2-core</artifactId>
-                <version>2.3.8</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.struts</groupId>
-                <artifactId>struts2-tiles-plugin</artifactId>
-                <version>2.3.8</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.struts</groupId>
-                <artifactId>struts2-spring-plugin</artifactId>
-                <version>2.3.8</version>
-            </dependency>
-
-            <!-- <dependency>
-                <groupId>com.google.inject.integration</groupId>
-                <artifactId>guice-struts2-plugin</artifactId>
-                <version>2.0</version>
-                <type>jar</type>
-                <scope>compile</scope>
-                <exclusions>
-                    <exclusion>
-                        <groupId>org.apache.struts</groupId>
-                        <artifactId>struts2-core</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>opensymphony</groupId>
-                        <artifactId>xwork</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency> -->
-
-            <dependency>
-                <groupId>org.apache.tiles</groupId>
-                <artifactId>tiles-core</artifactId>
-                <version>2.0.6</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tiles</groupId>
-                <artifactId>tiles-api</artifactId>
-                <version>2.0.6</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tiles</groupId>
-                <artifactId>tiles-jsp</artifactId>
-                <version>2.0.6</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.velocity</groupId>
-                <artifactId>velocity</artifactId>
-                <version>1.7</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.texen</groupId>
-                <artifactId>texen</artifactId>
-                <version>1.0</version>
-                <scope>provided</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.xmlrpc</groupId>
-                <artifactId>xmlrpc-common</artifactId>
-                <version>3.1.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.xmlrpc</groupId>
-                <artifactId>xmlrpc-client</artifactId>
-                <version>3.1.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.xmlrpc</groupId>
-                <artifactId>xmlrpc-server</artifactId>
-                <version>3.1.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.ws.commons.util</groupId>
-                <artifactId>ws-commons-util</artifactId>
-                <version>1.0.2</version>
-            </dependency>
-
-            <!-- Java EE deps -->
-
-            <dependency>
-                <groupId>org.apache.openjpa</groupId>
-                <artifactId>openjpa</artifactId>
-                <version>${openjpa.version}</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <!-- Next three EclipseLink JPA usage only -->
-
-            <dependency>
-                <groupId>org.eclipse.persistence</groupId>
-                <artifactId>eclipselink</artifactId>
-                <version>2.5.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jta_1.1_spec</artifactId>
-                <version>1.1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jpa_2.0_spec</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <!-- Next two Hibernate JPA usage only -->
-
-            <dependency>
-                <groupId>org.hibernate</groupId>
-                <artifactId>hibernate-entitymanager</artifactId>
-                <version>4.2.1.Final</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.slf4j</groupId>
-                <artifactId>slf4j-jdk14</artifactId>
-                <version>1.6.1</version>
-            </dependency>
-
-            <dependency>
-	            <groupId>commons-pool</groupId>
-	            <artifactId>commons-pool</artifactId>
-	            <version>1.5.4</version>
-            </dependency>
-
-            <dependency>
-                <groupId>javax.mail</groupId>
-                <artifactId>mail</artifactId>
-                <version>1.4</version>
-                <scope>compile</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>javax.servlet</groupId>
-                <artifactId>servlet-api</artifactId>
-                <version>2.4</version>
-                <scope>provided</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>javax.servlet</groupId>
-                <artifactId>jstl</artifactId>
-                <version>1.2</version>
-            </dependency>
-
-            <!-- test deps -->
-
-            <dependency>
-                <groupId>junit</groupId>
-                <artifactId>junit</artifactId>
-                <version>4.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.derby</groupId>
-                <artifactId>derby</artifactId>
-                <version>${derby.version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.derby</groupId>
-                <artifactId>derbynet</artifactId>
-                <version>${derby.version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.derby</groupId>
-                <artifactId>derbyclient</artifactId>
-                <version>${derby.version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>simple-jndi</groupId>
-                <artifactId>simple-jndi</artifactId>
-                <version>0.11.4</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.ant</groupId>
-                <artifactId>ant</artifactId>
-                <version>1.7.1</version>
-            </dependency>
-
-        </dependencies>
-    </dependencyManagement>
-</project>
+</project>
\ No newline at end of file

Modified: roller/trunk/test-utils/pom.xml
URL: http://svn.apache.org/viewvc/roller/trunk/test-utils/pom.xml?rev=1491083&r1=1491082&r2=1491083&view=diff
==============================================================================
--- roller/trunk/test-utils/pom.xml (original)
+++ roller/trunk/test-utils/pom.xml Sat Jun  8 22:17:42 2013
@@ -11,10 +11,19 @@
         <relativePath>../pom.xml</relativePath>
     </parent>
 
-    <name>Roller Test Utilities - Trunk</name>
+    <name>roller-test-utils</name>
     <groupId>org.apache.roller</groupId>
     <artifactId>test-utils</artifactId>
 
+    <properties>
+        <testOutputDirectory>${project.build.testOutputDirectory}</testOutputDirectory>
+        <testMediaDir>  ${project.build.testOutputDirectory}${file.separator}mediafiles</testMediaDir>
+        <testUploadsDir>${project.build.testOutputDirectory}${file.separator}uploadsdir</testUploadsDir>
+        <testThemesDir> ${project.build.testOutputDirectory}${file.separator}themes</testThemesDir>
+        <testIndexDir>  ${project.build.testOutputDirectory}${file.separator}index</testIndexDir>
+        <testPlanetCache>${project.build.testOutputDirectory}${file.separator}planetcache</testPlanetCache>
+    </properties>
+
     <dependencies>
 
         <dependency>
@@ -26,36 +35,48 @@
         <dependency>
             <groupId>junit</groupId>
             <artifactId>junit</artifactId>
+            <version>4.11</version>
             <scope>compile</scope>
         </dependency>
 
         <dependency>
+            <groupId>commons-lang</groupId>
+            <artifactId>commons-lang</artifactId>
+            <version>2.4</version>
+        </dependency>
+
+        <dependency>
             <groupId>org.apache.ant</groupId>
             <artifactId>ant</artifactId>
+            <version>1.7.1</version>
             <scope>compile</scope>
         </dependency>
 
         <dependency>
             <groupId>commons-logging</groupId>
             <artifactId>commons-logging</artifactId>
+            <version>1.1.1</version>
             <scope>compile</scope>
         </dependency>
 
         <dependency>
             <groupId>org.apache.derby</groupId>
             <artifactId>derbyclient</artifactId>
+            <version>${derby.version}</version>
             <scope>compile</scope>
         </dependency>
 
         <dependency>
             <groupId>org.apache.derby</groupId>
             <artifactId>derby</artifactId>
+            <version>${derby.version}</version>
             <scope>compile</scope>
         </dependency>
 
         <dependency>
             <groupId>org.apache.derby</groupId>
             <artifactId>derbynet</artifactId>
+            <version>${derby.version}</version>
             <scope>compile</scope>
         </dependency>
 

Propchange: roller/trunk/test-utils/src/main/java/org/apache/roller/weblogger/ant/
------------------------------------------------------------------------------
  Reverse-merged /roller/branches/roller_mavenized/test-utils/src/main/java/org/apache/roller/weblogger/ant:r894711-895418
  Merged /roller/branches/fewer_modules/test-utils/src/main/java/org/apache/roller/weblogger/ant:r1465398-1491055



Mime
View raw message