roller-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Johnson (JIRA)" <j...@apache.org>
Subject [jira] Commented: (ROL-1910) Search doesn't work after upgrading from Roller 4 to Roller 5, RC4
Date Sat, 05 Mar 2011 23:03:45 GMT

    [ https://issues.apache.org/jira/browse/ROL-1910?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13003061#comment-13003061
] 

David Johnson commented on ROL-1910:
------------------------------------

I wonder if this is due to old search index and new version of Lucene, or something similar.

By default the search index directory is search.index.dir=${user.home}/roller_data/search-index

Try stopping Roller, deleting the contents of that directory and then restarting Roller. Roller
should attempt to re-index your entire blog, and it shouldn't take that long. If you have
logging turned on, you can see Roller print each entry title as it builds the index.

Add this to roller-custom.properties to enable debug logging for Roller search:
   log4j.logger.org.apache.roller.weblogger.business.search=DEBUG

Does that solve the problem?

- Dave

 




> Search doesn't work after upgrading from Roller 4 to Roller 5, RC4
> ------------------------------------------------------------------
>
>                 Key: ROL-1910
>                 URL: https://issues.apache.org/jira/browse/ROL-1910
>             Project: Roller
>          Issue Type: Bug
>          Components: Search
>    Affects Versions: 5.0
>            Reporter: Matt Raible
>            Assignee: Roller Unassigned
>             Fix For: 5.0
>
>
> See http://raibledesigns.com/rd/entry/upgraded_to_apache_roller_5

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message