roller-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Stevens (JIRA)" <nore...@atlassian.com>
Subject [Roller-JIRA] Commented: (ROL-1467) Roller web app won't start on Websphere 5.1
Date Wed, 04 Jul 2007 17:40:30 GMT

    [ http://opensource.atlassian.com/projects/roller/browse/ROL-1467?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_13847
] 

Andy Stevens commented on ROL-1467:
-----------------------------------

The same seems to happen on Websphere 5.1.1:

WebSphere Platform 5.1 [BASE 5.1.1 a0426.01] [JDK 1.4.2 cn1420-20040626] [ND 5.1.0.0 b0344.02]
Host Operating System is Windows 2003, version 5.2
Java version = J2RE 1.4.2 IBM Windows 32 build cn1420-20040626 (JIT enabled: jitc), Java Compiler
= jitc, Java VM name = Classic VM


> Roller web app won't start on Websphere 5.1
> -------------------------------------------
>
>                 Key: ROL-1467
>                 URL: http://opensource.atlassian.com/projects/roller/browse/ROL-1467
>             Project: Roller
>          Issue Type: Bug
>          Components: Installation
>    Affects Versions: 3.1
>         Environment: WebSphere Platform 5.1 [BASE 5.1.0.0 b0344.02] [ND 5.1.0.0 b0344.02]
>            Reporter: Andy Stevens
>            Assignee: Roller Unassigned
>
> I downloaded the Roller 3.1 binaries zip, and the extra jars from the dev.java.net site.
 Because Websphere is only Servlet 2.3, I edited the web.xml (added the appropriate DOCTYPE,
removed the namespace from the webapp element, removed the dispatcher elements from the filter
mappings so that the file validates okay and uncommented the mail session resource ref). 
Following the instructions in the installation guide, I've created a roller-custom.properties
(with appropriate hibernate.dialect, uploads.dir and search.index.dir) in WEB-INF/classes
and used "jar cvf" to create a .war file.  I set up a MySQL database and created server resources
for the datasource and mail session ("Test Connection" succeeds for the datasource).
> I've installed the war file as an application in Websphere 5.1, mapped the resources
to the references, chose the appropriate server & virtual host mappings, saved, synchronised
the nodes and restarted the server.  However, during startup the roller application refuses
to start, producing the messages:
> ApplicationMg A WSVR0200I: Starting application: roller
> WebContainer  A SRVE0169I: Loading Web Module: Roller Weblogger.
> WebGroup      E SRVE0054E: An error occurred while loading Web application
> DeployedAppli W WSVR0206E: Module, roller.war, of application, roller.ear/deployments/roller,
failed to start
> ApplicationMg W WSVR0101W: An error occurred starting, roller
> ApplicationMg A WSVR0217I: Stopping application: roller
> ApplicationMg A WSVR0220I: Application stopped: roller
> So I tried installing the app into Tomcat (5.5.17, bundled with Netbeans 5.5) instead,
and it started up just fine.
> Searching the web, I found some articles Jeff Chilton wrote (http://www.zatz.com/authors/authorpages/jeffchilton.html)
about his problems installing an earlier version of Roller into WSAD 5.1.2.1 (this was back
in Nov '04).  His symptoms seemed to be the same (i.e. the above messages), so guided by his
investigations I tried removing the roller-web.jar from WEB-INF/lib.  The application did
then succeed in starting, though it complained loudly about all the missing servlets etc.
 But the last line it outputs is
> ApplicationMg A WSVR0221I: Application started: roller
> which at least appears to rule out a problem with the deployment descriptor.
> I tried commenting out the various parts of the deployment descriptor (servlets &
mappings, filters & mappings, listeners), but it still wouldn't start.  The only thing
that lets it start up is removing that jar file.
> Any ideas what else I can do to get it running, or where I should start looking in the
code to try & figure it out?

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://opensource.atlassian.com/projects/roller/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message