roller-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boris (JIRA)" <nore...@atlassian.com>
Subject [Roller-JIRA] Commented: (ROL-1408) UTF-8
Date Wed, 16 May 2007 20:50:55 GMT

    [ http://opensource.atlassian.com/projects/roller/browse/ROL-1408?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_13750
] 

Boris commented on ROL-1408:
----------------------------

I have changed im mysql character set to UTF-8 after Roller instalation .

mysql> ALTER DATABASE `winsum` DEFAULT CHARACTER SET utf8 DEFAULT 
mysql> COLLATE tf8_general_ci;

I've also added UTF-8 support to server.xml <Connector port="8422" maxHttpHeaderSize="8192"
...
URIEncoding="UTF-8"/>

If I add a new entry to my roller with UTF-8 characters: "žćčšđ" as title and 
saved it, the new entry's Permalink  is not avaliable . If I use non UTF-8 charcters in title
it works fine.

Permalink: http://www.winsum.ws/roller/skupno/entry/%C5%BE%C4%87%C4%8D%C5%A1%C4%91

I deleted this entry, but I can reproduce it. 

Boris


> UTF-8
> -----
>
>                 Key: ROL-1408
>                 URL: http://opensource.atlassian.com/projects/roller/browse/ROL-1408
>             Project: Roller
>          Issue Type: Bug
>          Components: Weblog Editor
>    Affects Versions: 3.1
>         Environment: Linux
>            Reporter: Boris
>            Assignee: Roller Unassigned
>
> If I use UTF-8 character in title in new Entry, a blog is not shown in roller. I can
save it, edit it, but can't view. My language settings is Slovenian.
> Thanks!
> Boris

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://opensource.atlassian.com/projects/roller/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message