river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter <j...@zeus.net.au>
Subject Re: Reminder: [Vote] Release Apache River JTSK 3.0.0
Date Fri, 04 Mar 2016 22:20:26 GMT
This bug also exists in previous releases, it was exposed with the inclusion of the Groovy

Sent from my Samsung device.
  Include original message
---- Original message ----
From: Greg Trasuk <trasukg@stratuscom.com>
Sent: 05/03/2016 01:57:14 am
To: dev@river.apache.org
Subject: Re: Reminder: [Vote] Release Apache River JTSK 3.0.0

Changing my vote to +0 for the moment. 

OK, so what we have here is a build bug. 

If you do an ‘ant clean’ then ‘ant river-runtime’, all is good. 
Do ‘ant river-runtime’ again, you get the failure that Patricia is seeing.

If you ‘cd qa’ then do ‘ant run-categories’ the qa suite runs without error.  That target doesn’t attempt to rebuild the main distribution.  The ‘run’ target inside ‘qa’ _does_ rebuild the main distribution (I’m not sure why that was put in there, but that’s the way it’s been forever).  Hence it shows the error mentioned above.

When I was doing my testing, I ran ‘ant run-categories’ to run the test suite, so I didn’t see this build bug.

On the one hand, I’m inclined to cancel the vote, figure out the bug, and spin a new release.  That could potentially take a while, because the bug smells of a nasty circularity in the build (or it could be trivial).  

On the other hand, we did say that this was a “technology preview” release that is supposed to get 3.0.0 into the hands of potential users, knowing full well that there are a lot of changes from the 2.2 branch, and people might find operational bugs.  People have run the qa suite, and it the whole package probably works just fine.  And the licensing is fine.  So we could probably just go ahead and release it.

I’m not sure what to do.  Any opinions? 


Greg Trasuk. 
> On Mar 3, 2016, at 4:57 PM, Patricia Shanahan <pats@acm.org> wrote:

> The file wk1 in the attached zip is the result of: 
> pats@pats-acer1:/River_3.0/src/apache-river-3.0.0$ ant clean 2>&1 >wk1

> pats@pats-acer1:/River_3.0/src/apache-river-3.0.0$ ant -v 2>&1 >>wk1

> On 03/03/2016 09:01 AM, Greg Trasuk wrote: 
>> That’s quite odd.  Can you do an ‘ant clean’, then ‘ant -v’ and post the complete scrollback, from the ‘ant clean’ command, to the final ‘build failed’?

>> There is a chance, I suppose, that Ubuntu uses a different version of Java (i.e. OpenJDK rather than Oracle JDK) or has something else pre-installed that is interfering with the build.  I haven’t tried building on Ubuntu myself, but I’m pretty sure I’ve used OpenJDK at some point, and it was fine.

>> Cheers, 
>> Greg Trasuk 
>>> On Mar 3, 2016, at 11:35 AM, Patricia Shanahan <pats@acm.org> wrote:

>>> Tried that. I even went back and re-extracted the .zip file, in case prior attempts had left tire marks. After the extract I did

>>> ant 
>>> ant qa.run 
>>> and got the same errors. This is on Ubuntu. 
>>> Unfortunately, I cannot cast a binding vote for a release I cannot run.

>>> On 3/3/2016 6:20 AM, Greg Trasuk wrote: 
>>>> Try running just ‘ant’ before you do ‘ant qa.run’.  That should run the default build target.

>>>> It appears that ‘qa.run’ is skipping the step where it downloads the external dependencies.  ‘ant’ on its own should do the build, then ‘ant qa.run’ should work.

>>>> Cheers, 
>>>> Greg Trasuk 
>>>>> On Mar 2, 2016, at 8:26 PM, Patricia Shanahan <pats@acm.org> wrote:

>>>>> I seem to be missing some set-up that needs doing before "ant qa.run".

>>>>> ng: Class not found: groovy.lang.MetaMethod 
>>>>>     [java] Warning: Class not found: org.codehaus.groovy.reflection.ClassInfo

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.wrappers.Wrapper

>>>>>     [java] Warning: Class not found: groovy.langReference 
>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.callsite.CallSiteArray

>>>>>     [java] Warning: Class not found: groovy.lang.GroovyCodeSource

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.callsite.CallSite

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.GeneratedClosure

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.typehandling.ShortTypeHandling

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.ScriptBytecodeAdapter

>>>>>     [java] Warning: Class not found: groovy.lang.Closure 
>>>>>     [java] Warning: Class not found: groovy.lang.MetaClass

>>>>>     [java] Warning: Class not found: org.cliffc.high_scale_lib.NonBlockingHashMap

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.BytecodeInterface8

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.ArrayUtil

>>>>>     [java] Warning: Class not found: groovy.lang.GroovyObject

>>>>>     [java] Warning: Class not found: groovy.lang.GroovyClassLoader

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.typehandling.DefaultTypeTransformation

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.control.CompilerConfiguration

>>>>>     [java] Warning: Class not found: org.codehaus.groovy.runtime.GStringImpl

>>>>>     [java] Warning: Class not found: groovy.lang.MissingPropertyException

>>>>>      [jar] Building jar: /River_3.0/src/apache-river-3.0.0/lib/jsk-platform.jar

>>>>>     [java] no text found: "preflistgen.error" 
>>>>>     [java] java.lang.NoClassDefFoundError: org/codehaus/groovy/runtime/GeneratedClosure

>>>>>     [java]     at java.lang.ClassLoader.defineClass1(Native Method)

>>>>>     [java]     at java.lang.ClassLoader.defineClass(ClassLoader.java:800)

>>>>>     [java]     at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)

>>>>>     [java]     at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)

>>>>>     [java]     at java.net.URLClassLoader.access$100(URLClassLoader.java:71)

>>>>>     [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:361)

>>>>>     [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:355)

>>>>>     [java]     at java.security.AccessController.doPrivileged(Native Method)

>>>>>     [java]     at javanet.URLClassLoader.findClass(URLClassLoader.java:354)

>>>>>     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:425)

>>>>>     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

>>>>>     [java]     at java.lang.Class.forName0(Native Method)

>>>>>     [java]     at java.lang.Class.forName(Class.java:278)

>>>>>     [java]     at org.apache.river.tool.PreferredListGen.compute(PreferredListGen.java:1162)

>>>>>     [java]     at org.apache.river.tool.PreferredListGen.main(PreferredListGen.java:1420)

>>>>>     [java] Caused by: java.lang.ClassNotFoundException: org.codehaus.groovy.runtime.GeneratedClosure

>>>>>     [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:366)

>>>>>     [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:355)

>>>>>     [java]     at java.security.AccessController.doPrivileged(Native Method)

>>>>>     [java]     at java.net..URLClassLoader.findClass(URLClassLoader.java:354)

>>>>>     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:425)

>>>>>     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

>>>>>     [java]     ... 15 more 
>>>>> /River_3.0/src/apache-river-3.0.0/build.xml:2205: The following error occurred while executing this line:

>>>>> /River_3.0/src/apache-river-3.0.0/qa/build.xml:144: The following error occurred while executing this line:

>>>>> /River_3.0/src/apache-river-3.0.0/build.xml:973: The following error occurred while executing this line:

>>>>> /River_3.0/src/apache-river-3.0.0/common.xml:253: Java returned: 1

>>>>> On 03/02/2016 04:20 PM, Peter wrote: 
>>>>>> ant qa.run 
>>>>>> ant test 
>>>>>> Regards, 
>>>>>> Peter. 
>>>>>> Sent from my Samsung device. 
>>>>>>     Include original message 
>>>>>> ---- Original message ---- 
>>>>>> From: Patricia Shanahan <pats@acm.org> 
>>>>>> Sent: 03/03/2016 09:44:57 am 
>>>>>> To: dev@river.apache.org 
>>>>>> Subject: Re: Reminder: [Vote] Release Apache River JTSK 3.0.0

>>>>>> I have built from the release artifacts, on a Ubuntu box. What is the

>>>>>> simplest way of running some tests against my build result?

>>>>>> On 3/2/2016 2:25 PM, Patricia Shanahan wrote: 
>>>>>>>  I have just got done with another project that was my highest priority

>>>>>>>  for a couple of weeks. I'll attempt to build and test so that I can cast

>>>>>>>  a binding vote. 
>>>>>>>  On 3/2/2016 12:12 PM, Greg Trasuk wrote: 
>>>>>>>>  Hi folks - we’re still short one binding vote for this release.  So,

>>>>>>>>  if you can, please have a look at the artifacts and have your say..

>>>>>>>>  Cheers, 
>>>>>>>>  Greg Trasuk 
>>>>>>>>>  On Feb 23, 2016, at 3:43 PM, Greg Trasuk <trasukg@stratuscom.com> wrote:

>>>>>>>>>  Hello all: 
>>>>>>>>>  Release candidate artifacts can be found at

>>>>>>>>>  https://dist.apache.org/repos/dist/dev/river/ 
>>>>>>>>>  Binary release artifacts are staged in 
>>>>>>>>>  https://repository.apache.org/content/repositories/orgapacheriver-1003/

>>>>>>>>>  The vote will remain open for at least 72 hours (Ending no sooner

>>>>>>>>>  than 2100UTC 20160226. 
>>>>>>>>>  [  ] +1 : I am in favour of this release

>>>>>>>>>  [  ] +0 : I am not opposed to this release.

>>>>>>>>>  [  ] -1: I am against this release (please provide your reasons).

>>>>>>>>>  Cheers, 
>>>>>>>>>  Greg Trasuk 
> <wk1.zip> 

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message