river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Rollo <danro...@gmail.com>
Subject Re: Test Failures on ARM, maybe I'm missing setup?
Date Fri, 22 Jan 2016 03:22:33 GMT
Just a quick ping to see if this patch to remove the “-server” switch could get into trunk?

Thanks,
Dan



Subject	Re: Test Failures on ARM, maybe I'm missing setup?
Date	Tue, 05 Jan 2016 22:39:05 GMT
Thanks Dan, consider it removed.

Sent from my Samsung device.
 
  Include original message
---- Original message ----
From: Dan Rollo <danrollo@gmail.com>
Sent: 06/01/2016 05:34:26 am
To: Cc: dev@river.apache.org
Subject: Re: Test Failures on ARM, maybe I'm missing setup?

I couldn’t find a way to detect if the “-server” switch would be supported without actually
running the jvm, and then searching the value of a system property (like: System.getProperty("java.vmname"))
for the text: “server”. Seems nasty.


FWIW, the following docs suggest the “-server” mode is the default now on non-32 bit jvms:

(http://docs.oracle.com/javase/8/docs/technotes/tools/unix/java.html - same doc info for other
os flavors)


-server 
Selects the Java HotSpot Server VM. The 64-bit version of the JDK supports only the Server
VM, so in that case the option is implicit.


I guess I'm trying to make the case that just removing the “-server” arg is acceptable.
:)


Dan 


…

> On Jan 4, 2016, at 5:20 PM, Dan Rollo <danrollo@gmail.com> wrote:
> 
> Thanks Greg, and Peter. I was able to apply the “remove -server” fix to qaDefaults.properties,
and the test ran fine on a Pi. I’ve attached a patch with these fixes against trunk. If
there is a better way to submit such a patch, please point me in the right direction ( - dare
I ask about git? :) .
> 
> Dan
> 
> 
> 
> <ARM_testVMArg_fix_remove_server_arg.patch>


Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message