river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Creswell <dan.cresw...@gmail.com>
Subject Re: Problem starting the reggie service
Date Fri, 13 Jan 2012 09:20:07 GMT
Hello,

My mind is aged so I may or may not be remembering correctly but I
think that means of starting reggie only work in Jini 1.x.

As of Jini 2.x and the following River project we use the service
starter in start.jar for the purpose of booting services. Two things
then:

(1) Could you please explain where you found the documentation that
suggests using the command-line for reggie you have below - it's
broken and needs fixing?
(2) Please see the following URL for examples of command-lines that
work: http://river.apache.org/user-guide-basic-river-services.html

Dan.


On 13 January 2012 07:47, Girbea Alina <alina.girbea@unitbv.ro> wrote:
> Hi,
>
> I'm trying to set up the most basic Jini application, but I haven't gone
> very far.
> First I've started the Jini HTTP server using the following command line:
>
>        java -jar tools.jar -dir D:\jini\apache-river-2.1.2-bin\lib-dl
>
> Now I'm trying to start the reggie lookup service on this server, using the
> following command line (first I'm trying to start everything on the same
> machine):
>
>       java -jar D:\jini\apache-river-2.1.2-bin\lib\reggie.jar
> http:\\localhost:8080\reggie-dl.jar D:\policy.all D:\tmp\reggie_log public
>
> Unfortunately, I get the following error message: "Failed to load Main-Class
> manifest attribute from: D:\jini\apache-river-2.1.2-bin\lib\reggie.jar"
> I've tried this both with version 2.2.0 and 2.1.2 and I get the same error
> messgae. Furthermore, I've looked into the source code classes of reggie,
> but I couldn't find any main function in any of the classes.
> How can I solve this issue?
> Thank you very much.
>
> Best Regards,
> Girbea Alina

Mime
View raw message