river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patricia Shanahan <p...@acm.org>
Subject Release 2.2 comments
Date Tue, 28 Jun 2011 03:41:38 GMT
I downloaded the source, and tried a naive build on Windows XP, Cygwin. 
I put a JDK 1.5 bin directory at the start of my path, and ran "ant 
all.build". It failed with the following errors:

compile:
     [javac] Compiling 1993 source files to C:\Documents and 
Settings\Administrator\My 
Documents\River_2.2\apache-river-2.2.0-src\apache-river-2.2.0\qa\build\classes
     [javac] C:/Documents and Settings/Administrator/My 
Documents/River_2.2/apache-river-2.2.0-src/apache-river-2.2.0/qa/src/com/sun/jini/test/impl/reggie/NameServiceImpl.java:29:

com.sun.jini.test.impl.reggie.NameServiceImpl is not abstract and does 
not override abstract method lookupAllHostAddr(java.lang.String) in 
sun.net.spi.nameservice.NameService
     [javac] public class NameServiceImpl implements NameService {
     [javac]        ^
     [javac] C:/Documents and Settings/Administrator/My 
Documents/River_2.2/apache-river-2.2.0-src/apache-river-2.2.0/qa/src/com/sun/jini/test/impl/reggie/NameServiceImpl.java:42:

lookupAllHostAddr(java.lang.String) in 
com.sun.jini.test.impl.reggie.NameServiceImpl cannot implement 
lookupAllHostAddr(java.lang.String) in 
sun.net.spi.nameservice.NameService; attempting to use incompatible 
return type
     [javac] found   : java.net.InetAddress[]
     [javac] required: byte[][]
     [javac]     public InetAddress[] lookupAllHostAddr(String host)
     [javac]                          ^
     [javac] Note: Some input files use or override a deprecated API.
     [javac] Note: Recompile with -Xlint:deprecation for details.
     [javac] Note: Some input files use unchecked or unsafe operations.
     [javac] Note: Recompile with -Xlint:unchecked for details.
     [javac] 2 errors

(I'm not worried about the deprecated APIs, just the compile failures.)

I next tried to find instructions. I looked at 
src-doc/static/build.html. It says "The bin directory of the Java(TM) 2 
SDK, Standard Edition, v 1.4 (or later) must be in your executable 
search path."

I believe we now need 1.5 or later.

Patricia



Mime
View raw message