river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Hobbs <tvho...@googlemail.com>
Subject Re: new release?
Date Tue, 16 Nov 2010 16:12:08 GMT
I thought that was the case.  I just couldn't tell from all the emails
if I'd missed a "I've fixed TestEquals" somewhere in the middle of it.

I ran the specific test by executing the following:

cd $RIVER_HOME

jtreg -verbose:all,nopass /
-cpa:../JTLib-tmp/jsk-lib.jar:/
../JTLib-tmp/jsk-platform.jar:/
../JTLib-tmp/jsk-policy.jar:/
../JTLib-tmp/jsk-resources.jar:/
../JTLib-tmp/phoenix-init.jar /
-jdk:"$JAVA_HOME" /
-Djsk.home="C:\development\projects\River" /
-Djavatest.maxOutputSize=500000 /
-Djava.protocol.handler.pkgs=net.jini.url /
-Djtlib.tmp=../JTLib-tmp /
net/jini/url/httpmd/TestEqual.java

It wouldn't surprise me if me if the command is wrong and that might
explain the problem.  I've been putting together this page
http://river.staging.apache.org/building-river.html to help people
with running the tests.  I'd appreciate your input.

Thanks.

On Tue, Nov 16, 2010 at 3:58 PM, Patricia Shanahan <pats@acm.org> wrote:
> Tom Hobbs wrote:
>>
>> Sorry, I'm getting lost in all the logs flying around.
>>
>> Is the jtreg test "net/jini/url/httpmd/TestEqual.java" still failing
>> for everyone?  You guys are just going on about the other two qa/.td
>> tests, right?
>
> ...
>>
>> Which seems to be different from everyone elses errors.  So what have
>> done differently?  Right now I'm running this test in WinXp and
>> cygwin.  I get the same result with JDK 15 and 1.6.
>
> I've only been looking at the QA failures. I've been busy with non-Apache
> activities, but I'll try to run that test both on WinXP+cygwin and on
> Ubuntu.
>
> To save me a little time and mail searching, could you give the instructions
> for running a specific jtreg test?
>
> Thanks,
>
> Patricia
>

Mime
View raw message