river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Hobbs <tvho...@googlemail.com>
Subject JTReg TestEquals failure (was Re: new release?)
Date Tue, 16 Nov 2010 16:03:14 GMT
Sorry, I'm convinced it's something stupid I'm doing.  But I can't find it.

The following command yields the same result;

$ jtreg -verbose:all,nopass /
-cpa:../JTLib-tmp/jsk-lib.jar:/
../JTLib-tmp/jsk-platform.jar:/
../JTLib-tmp/jsk-policy.jar:/
../JTLib-tmp/jsk-resources.jar:/
../JTLib-tmp/phoenix-init.jar /
-jdk:"$JAVA_HOME" /
-Djsk.home="C:\development\projects\River" /
-Djavatest.maxOutputSize=500000 /
-Djava.protocol.handler.pkgs=net.jini.url /
-Djtlib.tmp=../JTLib-tmp net/jini/url/httpmd/TestEqual.java

Gives the same "unknown protocol: httpmd" error.

I was reading here
(http://people.apache.org/~fbarnaby/river/2.1.1/previous/rm/tmp/apache-river-2.1.1/source/src/com/sun/jini/example/hello/)
that it could be something to do with running a secure reggie and
unsecured client code.  But I don't think that applies in this case.

Does everyone else have this thing working?  Has it been fixed already?

Cheers.

On Tue, Nov 16, 2010 at 3:35 PM, Tom Hobbs <tvhobbs@googlemail.com> wrote:
> Sorry, I'm getting lost in all the logs flying around.
>
> Is the jtreg test "net/jini/url/httpmd/TestEqual.java" still failing
> for everyone?  You guys are just going on about the other two qa/.td
> tests, right?
>
> Using the incantation:
>
> $ jtreg -verbose:all -jdk:"$JAVA_HOME" net/jini/url/httpmd/TestEqual.java
>
> I get the following error:
>
> java.lang.ExceptionInInitializerError
>        at java.lang.Class.forName0(Native Method)
>        at java.lang.Class.forName(Class.java:164)
>        at com.sun.javatest.regtest.MainWrapper$MainThread.run(MainWrapper.java:88)
>        at java.lang.Thread.run(Thread.java:595)
> Caused by: java.lang.RuntimeException: Unexpected exception:
> java.net.MalformedURLException: unknown protocol: httpmd
>        at UnitTestUtilities.unexpectedException(UnitTestUtilities.java:318)
>        at TestEqual.<init>(TestEqual.java:167)
>        at TestEqual.<init>(TestEqual.java:158)
>        at TestEqual.<clinit>(TestEqual.java:37)
>        ... 4 more
> STATUS:Failed.`main' threw exception: java.lang.ExceptionInInitializerError
>
> Which seems to be different from everyone elses errors.  So what have
> done differently?  Right now I'm running this test in WinXp and
> cygwin.  I get the same result with JDK 15 and 1.6.
>
> Cheers,
>
> Tom
>

Mime
View raw message