river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sim IJskes - QCG <...@qcg.nl>
Subject Re: Build failed in Hudson: River-trunk-jdk1.5 #3
Date Tue, 23 Nov 2010 16:15:44 GMT
On 23-11-10 17:03, Tom Hobbs wrote:
> Is Hudson using JDK6?
>
> I'm tempted to think that it is because it was compiling with the two
> JDK6 features that we committed fixes for today.  Will forcing it to
> be using JDK5 fix it?

No. I've created a new hudson job for building with jdk1.5. That showed 
the same errors as you produced with your jdk15 build. It turned out i 
made a jdk6 construct in ClassServer, which i changed into 1.5. I 
believe you committed a fix as well.

But it turns out sun changed the class 
sun.net.spi.nameservice.NameService between 1.5 and 6.

Thats why it errors on your (and hudsons new) jdk1.5 build.

Lucky (well?) this is only in the qa tests.

In order to make a decision/think of a fix i need a clear version 
support policy. Not something i need to trawl the mailing list archives 
for. Anybody else having the same opinion?

Gr. Sim

-- 
QCG, Software voor het MKB, 071-5890970, http://www.qcg.nl
Quality Consultancy Group b.v., Leiderdorp, Kvk Den Haag: 28088397

Mime
View raw message