river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Firmstone <j...@zeus.net.au>
Subject Re: new release?
Date Sat, 13 Nov 2010 08:46:31 GMT
Patricia Shanahan wrote:
> On 11/12/2010 4:25 PM, Peter Firmstone wrote:
>> Patricia Shanahan wrote:
>>> On 11/12/2010 1:56 PM, Peter Firmstone wrote:
>>>> Patricia Shanahan wrote:
>>>>> Peter Firmstone wrote:
>>>>>> Sim IJskes - QCG wrote:
>>>>>>> Now that we have the QA testing working, a very important step,
>>>>>>> should we go for a release?
>>>>>>>
>>>>>>> My personal feelings are: It is really a big step, which merits
a
>>>>>>> release on its own.
>>>>>>>
>>>>>>> Gr. Sim
>>>>>>>
>>>>>>>
>>>>>> Yes definitely soon, there are still two failing qa and one jtreg
>>>>>> test I'd like to look at, if I get some time over the weekend, I'll
>>>>>> investigate setting up the KDC also, then we should release.
>>>>>
>>>>> Would you like me to look at one of the failing tests? I can't 
>>>>> promise
>>>>> anything because I have a lot of non-Apache commitments over the
>>>>> weekend.
>>>>>
>>>>> Patricia
>>>>>
>>>>>
>>>> Yes please ;)
>>>>
>>>> The failling tests are:
>>>>
>>>> 1. Jtreg: qa/jtreg/net/jini/url/httpmd/TestEqual.java
>>>> 2. QA: com/sun/jini/test/impl/start/ServiceStarterCreateBad
>>>> TransientServiceTest.td
>>>> 3. QA: com/sun/jini/test/impl/start/ServiceStarterCreateSha
>>>> redBadActServiceTest.td
>>>>
>>>> Note the QA tests pass with JDK 1.5 but fail with JDK 1.6
>>>>
>>>> Build is compiled with 1.6.
>>> ...
>>>
>>> I can't reproduce the QA failures. I compiled and ran with JDK
>>> 1.6.0_22, and with no differences between my working River and the
>>> trunk head. Any ideas on how to get them to happen?
>>>
>>> Patricia
>>>
>>>
>>>
>> I ran against JDK 1.6.0_07, I'll try a later version, perhaps the QA
>> tests are caused by JDK bugs, need to identify the bug if this is the 
>> case.
>
> They pass with JDK 1.6.0_07. I think there must be some difference 
> other than JDK version that matters here.
>
> Patricia
>
Thank you, has anyone tried using a debugger with the qa tests?  I think 
I need to step though this one.

Cheers,

Peter.

Mime
View raw message