river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Costers <jonathan.cost...@googlemail.com>
Subject Re: all QA tests pass on ubuntu2!
Date Sun, 19 Sep 2010 12:59:33 GMT
I seem to be having the same issue on a fresh OpenSolaris installation ...
Must be missing something obvious ...

2010/9/19 Jonathan Costers <jonathan.costers@googlemail.com>

> does http://ant.apache.org/manual/install.html#optionalTasks help?
>
> 2010/9/19 Patricia Shanahan <pats@acm.org>
>
> Unfortunately, I'm currently stuck at the build stage. Each build fails
>> with the following message:
>>
>> BUILD FAILED
>> /export/home/pats/River/trunk/build.xml:2161: Problem: failed to create
>> task or type junit
>> Cause: the class org.apache.tools.ant.taskdefs.optional.junit.JUnitTask
>> was not found.
>>        This looks like one of Ant's optional components.
>> Action: Check that the appropriate optional JAR exists in
>>        -/usr/lib
>>        -/export/home/pats/.ant/lib
>>        -a directory added on the command line with the -lib argument
>>
>> Do not panic, this is a common problem.
>> The commonest cause is a missing JAR.
>>
>> This is not a bug; it is a configuration problem
>>
>>
>> I've tried scattering junit.jar files around, including the suggested
>> locations, but it does no good. Any suggestions on what to put where to fix
>> this? This is a shiny new OpenSolaris environment.
>>
>> Patricia
>>
>>
>>
>>
>>
>> On 9/18/2010 1:58 PM, Jonathan Costers wrote:
>>
>>> 2010/9/18 Patricia Shanahan<pats@acm.org>
>>>
>>>  I've created an Open Solaris installation in a VirtualBox. I'm in the
>>>> process of installing software, such as a JDK, on it.
>>>>
>>>> Regardless of whether it reproduces this specific problem, it will give
>>>> us
>>>> another test configuration - the more the better.
>>>>
>>>>
>>>>  Great news! I'd like to do the same when I get a chance
>>>
>>>
>>>
>>>>
>>>>
>>>> On 9/18/2010 1:10 AM, Jonathan Costers wrote:
>>>>
>>>>  Hmmm
>>>>>
>>>>> Hudson just finished a build (#24) on *solaris1*, and we still get that
>>>>> one
>>>>> failure:
>>>>>
>>>>> [java]
>>>>> com/sun/jini/test/spec/lookupdiscovery/MulticastMonitorAllChange.td
>>>>> [java] Test Failed: Test Failed:
>>>>> com.sun.jini.qa.harness.TestException: change failed -- waited 870
>>>>> seconds (14 minutes) -- 3 change event(s) expected, 0 change event(s)
>>>>> received
>>>>> [java]
>>>>>
>>>>> However, one *ubuntu1*, the same test passes ... (build #21)
>>>>> On my local machines, I have this test passing on both Linux and
>>>>> Windows.
>>>>> I do not have a Solaris installation available though, anyone?
>>>>>
>>>>> Would anyone be able to reproduce this situation?
>>>>> - pass the whole suite on Linux
>>>>> - fail the above test on Solaris
>>>>>
>>>>> Thanks
>>>>> Jonathan
>>>>>
>>>>> 2010/9/18 Peter Firmstone<jini@zeus.net.au>
>>>>>
>>>>>  Jonathan Costers wrote:
>>>>>
>>>>>>
>>>>>>  2010/9/17 Peter Firmstone<jini@zeus.net.au>
>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>  Jonathan, this progress is excellent news for anybody trying
to
>>>>>>>
>>>>>>>> actively
>>>>>>>> develop.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>  Are the rest of us allowed to commit to the trunk again
at this
>>>>>>> point?
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>  Definitely, cleared for takeoff.
>>>>>>>
>>>>>>
>>>>>> Cheers,
>>>>>>
>>>>>> Peter.
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message