river-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Dolan" <christopher.do...@avid.com>
Subject RE: sketches
Date Fri, 05 Feb 2010 15:32:11 GMT
If you use @Override only on methods that overload superclass methods
and not on methods that implement interface methods, then it will likely
work on JDK5, and the JDK6 dependency will not be needed.  The java.util
collections API barely changed at all between 5 and 6.

Did I hear Peter say that Java 1.5 is a goal for post-River 2.1.2?  If
so, it's a fairly simple chore to change 1.6 code to work with 1.5.  The
biggest changes that get me in trouble when I switch between the two
versions are @Override, String.isEmpty(), and a few Swing changes
(JTable, etc).

Chris

-----Original Message-----
From: Sim IJskes - QCG [mailto:sim@qcg.nl] 
Sent: Friday, February 05, 2010 2:24 AM
To: river-dev@incubator.apache.org
Subject: Re: sketches

Can i use @override and the collections framework? At least for the 
prototyping stage? If it works out, i can donate the code to the ASF and

  the committers can put it in a contrib directory, with the specific 
remark that it only compiles with jdk6.

Mime
View raw message