river-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsutomu YANO (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (RIVER-437) jsk-platform.jar doesn't contain net.jini.loader.RiverClassLoader in 2.2.2. Nobody try apache-river.
Date Tue, 25 Mar 2014 07:33:43 GMT

    [ https://issues.apache.org/jira/browse/RIVER-437?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13946254#comment-13946254

Tsutomu YANO commented on RIVER-437:

I tried the 2.2.2 binary distribution and then reggie worked correctly and my client worked
with the reggie!
Sorry this ticket depended on my mistaken (using the trunk source for running reggie). Issue
is resolved.

Thank you.

> jsk-platform.jar doesn't contain net.jini.loader.RiverClassLoader in 2.2.2. Nobody try
> ----------------------------------------------------------------------------------------------------
>                 Key: RIVER-437
>                 URL: https://issues.apache.org/jira/browse/RIVER-437
>             Project: River
>          Issue Type: Bug
>          Components: net_jini_loader
>    Affects Versions: River_2.2.2
>         Environment: Java(TM) SE Runtime Environment (build 1.7.0_51-b13) on Mac OS X
>            Reporter: Tsutomu YANO
> I updated the version of apache-river on maven pom.xml from 2.2.1 to 2.2.2. But my project
doesn't work with error bellow:
> java.lang.NoClassDefFoundError: net/jini/loader/RiverClassLoader
>         at com.sun.jini.reggie.ServiceTypeBase.setCodebase(ServiceTypeBase.java:54) ~[na:na]
>         at com.sun.jini.reggie.ClassMapper.toServiceTypeBase(ClassMapper.java:82) ~[na:na]
>         at com.sun.jini.reggie.ClassMapper.toServiceTypeBase(ClassMapper.java:55) ~[na:na]
>         at com.sun.jini.reggie.Item.<init>(Item.java:121) ~[na:na]
>         at com.sun.jini.reggie.RegistrarProxy.register(RegistrarProxy.java:102) ~[na:na]
>         at net.jini.lookup.JoinManager$ProxyReg.register(JoinManager.java:1223) ~[jsk-lib-2.2.2.jar:na]
>         at net.jini.lookup.JoinManager$RegisterTask.run(JoinManager.java:785) ~[jsk-lib-2.2.2.jar:na]
>         at net.jini.lookup.JoinManager$ProxyRegTask.tryOnce(JoinManager.java:609) ~[jsk-lib-2.2.2.jar:na]
>         at com.sun.jini.thread.RetryTask.run(RetryTask.java:131) ~[jsk-lib-2.2.2.jar:na]
>         at com.sun.jini.thread.TaskManager$TaskThread.run(TaskManager.java:331) ~[jsk-lib-2.2.2.jar:na]
> Caused by: java.lang.ClassNotFoundException: net.jini.loader.RiverClassLoader
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:372) ~[na:1.8.0]
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[na:1.8.0]
>         at java.security.AccessController.doPrivileged(Native Method) ~[na:1.8.0]
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:360) ~[na:1.8.0]
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[na:1.8.0]
>         at net.jini.loader.pref.PreferredClassLoader.loadClass(PreferredClassLoader.java:942)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[na:1.8.0]
>         ... 10 common frames omitted
> It seems like jar from maven central repository doesn't conain RiverClassLoader.
> I checked jsk-platform.jar on 2.2.1 and new 2.2.2. 2.2.1 contains RiverClassLoader but
2.2.2. doesn't.
> Then I built from source of trunk of svn. But the built jar doesn't contain RiverClassLoader.
There are no classes in net.jini.loader package.
> If this issue isn't my mistake but really is a mistake of building, I think it is really
big problem for apache river project, because currently NOBODY can try apache-river.
> I hope I can make my program work with river 2.2.2.

This message was sent by Atlassian JIRA

View raw message