river-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Brouwer (JIRA)" <j...@apache.org>
Subject [jira] Updated: (RIVER-21) HTTP based server endpoints only work reliable over mod_proxy when downgrading to HTTP 1.0
Date Tue, 24 Jul 2007 07:57:31 GMT

     [ https://issues.apache.org/jira/browse/RIVER-21?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mark Brouwer updated RIVER-21:
------------------------------

          Component/s: net_jini_jeri
    Affects Version/s: jtsk_2.1

> HTTP based server endpoints only work reliable over mod_proxy when downgrading to HTTP
1.0
> ------------------------------------------------------------------------------------------
>
>                 Key: RIVER-21
>                 URL: https://issues.apache.org/jira/browse/RIVER-21
>             Project: River
>          Issue Type: Bug
>          Components: net_jini_jeri
>    Affects Versions: jtsk_2.1
>            Reporter: Mark Brouwer
>
> During my work for "Jini across the Firewall" in which the client {{HttpEndpoint}} communicated
with an {{HttpServerEndpoint}} through {{mod_proxy}} (Apache 1.2.x and 2.x) I noticed I could
only have reliable connections when I downgraded the HTTP protocol in the Apache configuration
with:
> {noformat:nopanel}
> SetEnvIf User-Agent ".*com\.sun.*HttpClientConnection" downgrade-1.0
> {noformat}
> I was in the possession of some log files but given the timespan between submitting this
issue and the time I ran into the problems they seem to have disappeared. IIRC the {{HttpEndpoint}}
tried to initiate a request over an HTTP connection that was kept alive while the {{HttpServerEndpoint}}
thought otherwise.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message