reef-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mariia Mykhailova <mamyk...@microsoft.com.INVALID>
Subject RE: Test failure on AppVeyor when trying to run specific test
Date Wed, 28 Jun 2017 20:19:32 GMT
"...OnYarn" tests need to be executed on an actual Yarn environment, which AppVeyor doesn't
have. AppVeyor runs only local runtime tests.
REEF-1541 is open for work that needs to be done to allow to run "...OnYarn" tests - currently
there's no way to run them and verify the result automatically.

-Mariia

-----Original Message-----
From: ź¹€ė„ģ˜ [mailto:disoxc21@gmail.com] 
Sent: Wednesday, June 28, 2017 12:46 PM
To: dev@reef.apache.org
Subject: Test failure on AppVeyor when trying to run specific test

Hello!

Iā€™m trying to reproduce test failure in REEF-1462.

With recent build with REEF-1816, AppVeyor builds and passes all tests successfully.
But when I try to test specific tests, Test terminates with an Exception.

I edited appveyor.yml to test specific test as below referring instruction in cs/BUILD.md.

test_script:
- cmd: cd .\lang\cs
- cmd: .\.nuget\nuget.exe restore .\.nuget\packages.config -o .\packages
- cmd: .\packages\xunit.runner.console.2.1.0\tools\xunit.console.exe .\bin\x64\Debug\Org.Apache.REEF.Tests\Org.Apache.REEF.Tests.dll
-method Org.Apache.REEF.Tests.Functional.IMRU.TestFailMapperEvaluatorOnWaitingForEvaluatorAndExecution.TestFailedMapperOnLocalRuntime
- cmd: .\packages\xunit.runner.console.2.1.0\tools\xunit.console.exe .\bin\x64\Debug\Org.Apache.REEF.Tests\Org.Apache.REEF.Tests.dll
-method Org.Apache.REEF.Tests.Functional.IMRU.TestFailMapperEvaluatorOnWaitingForEvaluatorAndExecution.TestFailedMapperOnYarn

And Result are here.

It seems these errors occur when I try to test any yarn related test.
Am I trying to test in wrong way?

Thank you
Doyoung.

Mime
View raw message