reef-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Douglas Service <dsop...@gmail.com>
Subject Re: REEFJava build fails on Windows?
Date Tue, 04 Oct 2016 01:27:05 GMT
Are you cleaning from powershell or from visual studio?

Doug

On Mon, Oct 3, 2016 at 5:49 PM, Mariia Mykhailova <mamykhai@microsoft.com>
wrote:

> Interesting, I did get some failures after syncing to this commit, but for
> me it was sufficient to do a regular .NET clean for everything to start
> working again.
>
> function Clean-REEF-NET{
>     Invoke-Expression 'msbuild $REEFSourcePath\lang\cs\Org.Apache.REEF.sln
> /p:Configuration="Debug" /p:Platform="x64" /t:Clean /m /nr:false'
>     Get-ChildItem -Path $REEFSourcePath\lang\cs\ -Recurse -Filter obj
>           | Remove-Item -Recurse
>     Get-ChildItem -Path $REEFSourcePath\lang\cs\ -Recurse -Filter bin
>           | Remove-Item -Recurse
>     Get-ChildItem -Path $REEFSourcePath\lang\cs\ -Recurse -Filter target
>            | Remove-Item -Recurse
>     Get-ChildItem -Path $REEFSourcePath\lang\cs\ -Recurse -Filter
> REEF_LOCAL_RUNTIME | Remove-Item -Recurse
>     Get-ChildItem -Path $REEFSourcePath\lang\cs\ -Recurse -Filter
> TestResults        | Remove-Item -Recurse
> }
>
> -Mariia
>
> -----Original Message-----
> From: Douglas Service [mailto:dsopsrc@gmail.com]
> Sent: Monday, October 3, 2016 5:44 PM
> To: dev@reef.apache.org
> Subject: Re: REEFJava build fails on Windows?
>
> I just synced to Apache reef master and it builds. Your problem is
> probably from the commit below. I put a warning in the commit message since
> I had a very similar problem where I was getting test errors. To fix the
> problem, I ended up pushing all of my branches to github deleting my
> enlistment and then cloning my copy of REEF on github. You could probably
> also do a clean, roll back to the commit just before this one, do a clean,
> and then pull the latestest. I verified the problem only occurs if you do
> not do a clean in Visual Studio and Maven before syncing to the commit.
> There was some discussion on the dev list, but we probably need a better
> way to let every know about these kinds of issues.
>
> Doug
>
> [REEF-1611] Move Java .proto files to common directory
>
> This change moves the Java .proto files to lang/common/proto so the C#
> side can use the same proto files.
>
> WARNING: Before pulling this change you should clean both the Java and C#
> builds; otherwise, you will have artifacts this version cannot remove that
> cause test failures on the C# side.
>
> JIRA:
>     [REEF-1611](https://na01.safelinks.protection.outlook.
> com/?url=https%3A%2F%2Fissues.apache.org%2Fjira%2Fbrowse%
> 2FREEF-1611&data=01%7C01%7Cmamykhai%40microsoft.com%
> 7Cd3ccbd8898604b4fc16c08d3ebef9bd0%7C72f988bf86f141af91ab2d7cd011
> db47%7C1&sdata=%2B93eDf2dKPIbgXr%2FVLPmBqFUNm65EFxpMPcNMde2tsI%
> 3D&reserved=0)
>
> Pull Request:
>   This closes #1142 <https://na01.safelinks.protection.outlook.com/?url=
> https%3A%2F%2Fgithub.com%2Fapache%2Freef%2Fpull%2F1142&
> data=01%7C01%7Cmamykhai%40microsoft.com%7Cd3ccbd8898604b4fc16c08d3ebef
> 9bd0%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=HpdqNGdwXs%
> 2F9gR%2BBx%2FOXhlGQi%2FZRTFGnGCCs%2BKgn8MA%3D&reserved=0>
>
>
> On Mon, Oct 3, 2016 at 5:22 PM, Sergiy Matusevych <
> sergiy.matusevych@gmail.com> wrote:
>
> > Hi REEF devs,
> >
> > Can someone try to build current master from scratch? I am getting the
> > following error:
> >
> >     [exec]
> > C:\Users\sergiym.REDMOND\devel\reef\lang\java\reef-
> > wake\wake/../../../../lang/common/proto/RemoteProtocol.proto:
> > File does not reside within any path specified using --proto_path (or
> -I).
> > You must specify a --proto_path which encompasses this file.  Note
> > that the proto_path must be an exact prefix of the .proto file names
> > -- protoc is too dumb to figure out when two paths (e.g. absolute and
> > relative) are equivalent (it's harder than you think).
> >
> > and eventually it complains that java files that should be generated
> > from proto are not there. :(
> >
> > I've removed ~/.m2 and cloned the whole repo anew but I am still
> > getting this error. Am I the only one getting this error? Any ideas on
> > how to fix it?
> >
> > Thanks,
> > Sergiy.
> >
>



-- 

On Mon, Oct 3, 2016 at 5:50 PM, Markus Weimer <markus@weimo.de> wrote:
On Mon, Oct 3, 2016 at 4:55 PM, Douglas Service <dsopsrc@gmail.com> wrote:
> Questions:
> 1) If the extra messages are not used by both sides they should probably
> not be in this file. Will these messages be shared in the futur

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message