reef-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Boris Shulman <shulm...@gmail.com>
Subject Re: [VOTE] Release Apache REEF 0.15.0 (rc2)
Date Tue, 24 May 2016 19:45:14 GMT
He had yarn runtime mentioned in one of the traces. Maybe I am wrong here.

On Tue, May 24, 2016 at 12:03 PM, Mariia Mykhailova <mamykhai@microsoft.com>
wrote:

> I can't comment on the tests as long as I haven't seen logs for the
> failures. Unfortunately, our tests are not good at reporting the exact
> error in the message, they just say that something went wrong.
>
> By the way, Boris, which test is not supposed to run on local runtime but
> ran for Wooyeon?
>
> -Mariia
>
> -----Original Message-----
> From: Boris Shulman [mailto:shulmanb@gmail.com]
> Sent: Tuesday, May 24, 2016 7:27 AM
> To: dev@reef.apache.org
> Subject: Re: [VOTE] Release Apache REEF 0.15.0 (rc2)
>
> I will wait for Mariia's comments for the tests before publishing the
> artifacts.
>
> Sent from my iPhone
>
> > On May 24, 2016, at 7:16 AM, Yunseong Lee <yunseong.lee0@gmail.com>
> wrote:
> >
> > Hi Boris,
> >
> > Thanks for the hard work as the release manager! Technically the vote
> > seems to have passed as you mentioned.
> >
> > However, I'm a bit concerned that some users may encounter the same
> > problem with the release.
> >
> > Markus, what do you think of it?
> >
> > Regards,
> > Yunseong
> >> On Tue, May 24, 2016 at 11:04 PM Boris Shulman <shulmanb@gmail.com>
> wrote:
> >>
> >> I think the vote actually passed, as we had 3 +1s and no -1s. (From
> >> you myself and Yunseong).
> >>
> >> Sent from my iPhone
> >>
> >>> On May 24, 2016, at 1:13 AM, Dongjoon Hyun <dongjoon@apache.org>
> wrote:
> >>>
> >>> Unfortunately, the vote was posted on `Sat, May 21, 2016 at 1:02 AM`
> >>> and
> >> it's
> >>> over 72 hours.
> >>>
> >>> I'm not sure the current status of this VOTE.
> >>>
> >>> IMO, if we need more time for RC2, what about going to RC3 after
> >>> more preparation?
> >>>
> >>> Dongjoon.
> >>>
> >>>
> >>>> On Mon, May 23, 2016 at 7:35 PM, Boris Shulman <shulmanb@gmail.com>
> >> wrote:
> >>>>
> >>>> Mariia can you please take a look on this errors?
> >>>>
> >>>> Sent from my iPhone
> >>>>
> >>>>> On May 23, 2016, at 7:04 PM, Woo-Yeon Lee <wylee.xyzi@gmail.com>
> >> wrote:
> >>>>>
> >>>>> I've found a Dhruv's thread reporting these fails, made 7days ago.
> >>>>> (
> >> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fmail-
> >> archives.apache.org%2fmod_mbox%2freef-dev%2f201605.mbox%2f%253cCAO2Pp
> >> vtxd9ZCu-2tKU%2b3GPiy5iJPuu8bnUQTZ7Q_oz8GgYJKgQ%40mail.gmail.com%253e
> >> &data=01%7c01%7cmamykhai%40microsoft.com%7cdf299487d0be4b5acf2708d383
> >> df70f8%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=zzE5%2fkNJoKK6ngW
> >> aFl%2f0vEbxcAPZtoGLHeBtzUF6q7c%3d
> >>>>> )
> >>>>>
> >>>>> Also there's a Mariia's thread made 6 hours ago reporting "Cannot
> >>>>> read
> >>>> from
> >>>>> log files" error, which is included in error logs of Dhruv and I.
> >>>>> I'm mentioning it and adding a link, since this mail was
> >>>>> classified as
> >> `Junk`
> >>>>> mail by Gmail. So I guess that all the guys using Gmail do not
> >>>>> receive
> >>>> this.
> >>>>> (
> >> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fmail-
> >> archives.apache.org%2fmod_mbox%2freef-dev%2f201605.mbox%2f%253cBN3PR0
> >> 3MB2179623C35CEB17842C5F1E8D24E0%40BN3PR03MB2179.namprd03.prod.outloo
> >> k.com%253e&data=01%7c01%7cmamykhai%40microsoft.com%7cdf299487d0be4b5a
> >> cf2708d383df70f8%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=8R%2fU2
> >> Gb3tw3PZH9Tj9evdqdZOeW3ufOxbJsUV%2bOc1Ls%3d
> >>>>> )
> >>>>>
> >>>>> Thanks,
> >>>>> Wooyeon
> >>>>>
> >>>>>> On Tue, May 24, 2016 at 10:20 AM, Boris Shulman
> >>>>>> <shulmanb@gmail.com>
> >>>> wrote:
> >>>>>>
> >>>>>> Looks like that for some reason it rans yarn tests as well (multi
> >>>> runtime
> >>>>>> test is not supposed to run on local for example)
> >>>>>>
> >>>>>> Sent from my iPhone
> >>>>>>
> >>>>>>> On May 23, 2016, at 5:42 PM, Woo-Yeon Lee <wylee.xyzi@gmail.com>
> >>>> wrote:
> >>>>>>>
> >>>>>>> Thanks for response, Boris and Mariia.
> >>>>>>>
> >>>>>>> First, I re-ran the tests this time in `c:\reef`. (I did
> >>>>>>> previous
> >> tests
> >>>>>> in `c:\apache-reef-0.15.0`)
> >>>>>>> But it still gives me the same result (31 failed tests).
> >>>>>>>
> >>>>>>> I'm attaching a text file that I compiled error messages
of
> >>>>>>> fails,
> >>>>>> including stack traces, from VS13.
> >>>>>>>
> >>>>>>> To summarize, below two are major error messages.
> >>>>>>> - Expected number of contexts to close (4) differs from
actual
> >>>>>>> number
> >>>> of
> >>>>>> success indicators (0)
> >>>>>>> - Expected number of evaluators to fail (1) differs from
actual
> >> number
> >>>>>> of failed evaluator indicators (0)
> >>>>>>>
> >>>>>>> And there are several other messages:
> >>>>>>> - Expected number of message "I have seen a failed evaluator
> >>>>>>> with
> >>>>>> correct failed context and no task." occurrences 1 differs from
> >> actual 0
> >>>>>>> - Expected number of message "Runtime Name: Local" occurrences
2
> >>>> differs
> >>>>>> from actual 0
> >>>>>>> - Expected number of message "System.ArgumentException:
> >>>>>>> Requested
> >>>>>> runtime Yarn is not in the defined runtimes list Local"
> >>>>>> occurrences 1 differs from actual 0
> >>>>>>> - e.t.c.
> >>>>>>>
> >>>>>>> Thanks,
> >>>>>>> Wooyeon
> >>>>>>>
> >>>>>>>> On Tue, May 24, 2016 at 3:25 AM, Mariia Mykhailova <
> >>>>>> mamykhai@microsoft.com> wrote:
> >>>>>>>> TestPoisonedActiveContextHandlerImmediate failure might
be the
> >>>>>>>> same
> >>>>>> heisenbug we've been seeing on AppVeyor, but even there it
> >>>>>> doesn't
> >> fail
> >>>>>> consistently, more like once every 7-10 runs. And I never see
it
> >>>>>> on my machine, so it's probably some timing issue with the test
> itself.
> >>>> Markus,
> >>>>>> can you repro the failure on your machine consistently? Could
you
> >> please
> >>>>>> open a JIRA for it and attach driver and evaluator logs to see
> >>>>>> what
> >>>> happens
> >>>>>> in the test?
> >>>>>>>>
> >>>>>>>> For 31 failed tests, Woo-yeon, could you please share
the error
> >>>>>> messages?
> >>>>>>>>
> >>>>>>>> -Mariia
> >>>>>>>>
> >>>>>>>> -----Original Message-----
> >>>>>>>> From: Boris Shulman [mailto:shulmanb@gmail.com]
> >>>>>>>> Sent: Monday, May 23, 2016 8:16 AM
> >>>>>>>> To: dev@reef.apache.org
> >>>>>>>> Subject: Re: [VOTE] Release Apache REEF 0.15.0 (rc2)
> >>>>>>>>
> >>>>>>>> All tests pass locally for my (Win 10, VS 2013). Will
run HDI
> >>>>>>>> tests
> >> in
> >>>>>> couple of hours.
> >>>>>>>> Woo-Yeon,
> >>>>>>>> The tests will fail if the file system path will be
too long,
> >>>>>>>> so
> >>>> please
> >>>>>> put teh file in c:\reef or some thing similar.
> >>>>>>>>
> >>>>>>>> Boris.
> >>>>>>>>
> >>>>>>>> On Mon, May 23, 2016 at 2:19 AM, Woo-Yeon Lee
> >>>>>>>> <wylee.xyzi@gmail.com
> >>>
> >>>>>> wrote:
> >>>>>>>>
> >>>>>>>>>
> >>>>>>>>>> On May 23, 2016, at 6:15 PM, Woo-Yeon Lee
> >>>>>>>>>> <wylee.xyzi@gmail.com>
> >>>>>> wrote:
> >>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>>> On May 23, 2016, at 5:57 PM, Dongjoon Hyun
> >>>>>>>>>>> <dongjoon@apache.org>
> >>>>>> wrote:
> >>>>>>>>>>>
> >>>>>>>>>>> If then, Markus and you have correct setting,
and I was wrong.
> >>>>>>>>>>> We need independent test result reporting.
> >>>>>>>>>>> Please don't hesitate reporting!
> >>>>>>>>>>>
> >>>>>>>>>>> My environment was Windows 10 64bit on Parallels.
> >>>>>>>>>>> Maybe, mine is slow and inadequate?
> >>>>>>>>>>>
> >>>>>>>>>>> What is the number of total tests in your
test explorer?
> >>>>>>>>>>> - Failed: 31
> >>>>>>>>>>> - Passed: ?
> >>>>>>>>>>> - Skipped: ?
> >>>>>>>>>>
> >>>>>>>>>> Sorry for missing details.
> >>>>>>>>>>
> >>>>>>>>>> Total tests: 645
> >>>>>>>>>> Failed: 31
> >>>>>>>>>> Passed: 34
> >>>>>>>>>> Skipped: 580
> >>>>>>>>>
> >>>>>>>>> Fix: the number of Skipped and Passed were in a
wrong order.
> >>>>>>>>>
> >>>>>>>>> Failed: 31
> >>>>>>>>> Skipped: 34
> >>>>>>>>> Passed: 580
> >>>>>>>>>
> >>>>>>>>>> All the fails were under a “Org.Apache.REEF.Tests.Functional”
> >>>>>> package.
> >>>>>>>>>>
> >>>>>>>>>> I tested in a laptop with Windows 10 64bit (not
VM).
> >>>>>>>>>>
> >>>>>>>>>> Wooyeon
> >>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>> Dongjoon.
> >>>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>> On Mon, May 23, 2016 at 1:47 AM, Woo-Yeon
Lee
> >>>>>>>>>>> <wylee.xyzi@gmail.com>
> >>>>>>>>> wrote:
> >>>>>>>>>>>
> >>>>>>>>>>>> Hi, I tried testing REEF .NET.
> >>>>>>>>>>>>
> >>>>>>>>>>>> As a result I’ve met 31 test fails,
both in terminal and VS
> >> 2013.
> >>>>>>>>>>>> The
> >>>>>>>>> same
> >>>>>>>>>>>> set of tests always fail with retries
The result includes a
> >>>>>>>>>>>> fail of
> >> 'REEF.Tests.Functional.TestEvaluatorWithActiveContextImmediatePois
> >>>>>>>>>>>> on',
> >>>>>>>>>>>> which Markus already reported.
> >>>>>>>>>>>>
> >>>>>>>>>>>> But I’m afraid that I’m doing with
wrong settings, as
> >>>>>>>>>>>> Dongjoon said the tests pass in VS2013
in his environment.
> >>>>>>>>>>>> (Actually it’s the first time for
me to build and test C#
> REEF.
> >>>>>>>>>>>> I’ve
> >>>>>>>>> been
> >>>>>>>>>>>> using Java-side.)
> >>>>>>>>>>>>
> >>>>>>>>>>>> I wish it would be a help, and please
let me know if it’s
> >>>>>>>>>>>> due to my
> >>>>>>>>> wrong
> >>>>>>>>>>>> settings.
> >>>>>>>>>>>>
> >>>>>>>>>>>> Thanks,
> >>>>>>>>>>>> Wooyeon
> >>>>>>>>>>>>
> >>>>>>>>>>>>> On May 23, 2016, at 10:16 AM, Markus
Weimer
> >>>>>>>>>>>>> <markus@weimo.de>
> >>>>>> wrote:
> >>>>>>>>>>>>>
> >>>>>>>>>>>>> Hi,
> >>>>>>>>>>>>>
> >>>>>>>>>>>>> I have done some more investigation.
Tests on `master`
> >>>>>>>>>>>>> also
> >> fail
> >>>>>>>>>>>>> on
> >>>>>>>>> this
> >>>>>>>>>>>> machine. It isn't always the same test
that fails, but it
> >>>>>>>>>>>> always is an integration test of REEF.NET.
I'll refrain
> >>>>>>>>>>>> from voting
> >>>>>> until
> >>>>>>>>>>>> I've
> >>>>>>>>> tried
> >>>>>>>>>>>> on another machine.
> >>>>>>>>>>>>>
> >>>>>>>>>>>>> Markus
> >>>>>>>
> >>>>>>> <reef-dotnot-test-errors.txt>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message