reef-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dhruv Mahajan <dhruv.maha...@gmail.com>
Subject Re: Issues with running on yarn
Date Wed, 13 Apr 2016 17:03:03 GMT
Markus

Can you try running imru.examples example also?

Dhruv
On Apr 13, 2016 12:12 AM, "Boris Shulman" <shulmanb@gmail.com> wrote:

> Tests pass for me as well, but HelloReef crashed and IRMU example as
> well.They crash very early in the driver initialization without any usable
> traces. I ran all this (including on Yarn) before the merge.
>
> On Wed, Apr 13, 2016 at 12:09 AM, Markus Weimer <markus@weimo.de> wrote:
>
> > On 2016-04-12 21:58, Boris Shulman wrote:
> >
> >> Can you please also try and see what error you are getting?
> >>
> >
> > This is so weird. For every PR I merged the last couple of days (~10),
> the
> > tests passed on my work machine (12 cores, 2.x GHz Xeon). I just did a
> deep
> > clean as described earlier, followed by
> >
> > ```
> > $> msbuild .\lang\cs\Org.Apache.REEF.sln
> > $> msbuild .\lang\cs\TestRunner.proj
> > ```
> >
> > When I merged the PR that adds the multi-runtime support to .NET - which
> > seems to cause the issue here - I tested on 3 different machines (2 core
> > ultrabook, 6 core i7, 12 core Xeon) to rule out machine issues.
> >
> > Now, when I ran the tests just now on my home machine (6 Core, 4.4 GHz
> > i7), they just hung after a while. Sorry, I don't have logs, as I was too
> > eager to try again. On that second try, they passed.
> >
> > It seems to me that our tests are still a bit flaky.
> >
> > Markus
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message