reef-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Weimer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (REEF-936) Support scale-down in REEF
Date Thu, 04 Feb 2016 04:49:39 GMT

    [ https://issues.apache.org/jira/browse/REEF-936?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15131734#comment-15131734
] 

Markus Weimer commented on REEF-936:
------------------------------------

{{RuntimesContainer}} is a confusing name. It is not actually a container in the YARN sense,
right? Instead, it is an object which wraps the hashmap of actual runtimes. Maybe we need
a better name for this? E.g. {{RuntimeRouter}}?

> Support scale-down in REEF
> --------------------------
>
>                 Key: REEF-936
>                 URL: https://issues.apache.org/jira/browse/REEF-936
>             Project: REEF
>          Issue Type: Improvement
>          Components: REEF
>            Reporter: Markus Weimer
>            Assignee: Boris Shulman
>
> The minimal useful REEF job right now consists of two containers: One for the Driver
and one for the Evaluator. This is a fitting design for applications that need to scale out.
> However, some apps might need to be elastic to workloads the size of a single Task, at
which point the overhead for the Driver becomes substantial.
> While there is no plan of action yet, let's use this JIRA as the link target for future
work towards this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message