ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhay Kulkarni <akulka...@hortonworks.com>
Subject Re: Ranger not executing policies...
Date Mon, 09 Jul 2018 23:34:39 GMT
Bosco,

It appears from the log (lines 6, 7)  that the Trie search for resource (database=default)
did not find any policies. Per lines 3 and 5, it looks like the name of the policy resource
is set to 'database' instead of 'default'. Could you please check if the policies are correctly
downloaded to the component?

Thanks,
-Abhay


From: Don Bosco Durai <bosco@apache.org<mailto:bosco@apache.org>>
Reply-To: "dev@ranger.apache.org<mailto:dev@ranger.apache.org>" <dev@ranger.apache.org<mailto:dev@ranger.apache.org>>
Date: Monday, July 9, 2018 at 3:51 PM
To: ranger <dev@ranger.apache.org<mailto:dev@ranger.apache.org>>
Subject: Ranger not executing policies...

Hi Abhay

I have extended the work done by Kent Yao for supporting Ranger with SparkSQL ThriftServer.
I managed to integrate with the Ranger master branch and also the Ranger authorizer code is
called, but I always get denied by Ranger authorizer.

Earlier in the logs, I can see the policies getting downloaded and also the local .json file
is getting created. However, when the check privileges call is called, it seems it is not
able to get it. I am not sure if custom class loaders are interfering. Is it possible to dump
the policies when the authorization code is called?

I have attached part of the logs. Let me know if you can guide me in the right direction?

Thanks

Bosco


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message