ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pradeep Agrawal <pradeep.agra...@freestoneinfotech.com>
Subject Re: Review Request 65608: RANGER-1980: Build failure for Ranger 0.7 branch
Date Mon, 12 Feb 2018 14:29:22 GMT


> On Feb. 12, 2018, 2:27 p.m., Colm O hEigeartaigh wrote:
> > Why not just update to the released 0.8.2? We should avoid depending on SNAPSHOT
versions of other projects unless there is a good reason to do so.

Currently 0.8.2-SNAPSHOT jars are not available here https://repository.apache.org/content/repositories/snapshots/org/apache/atlas


- Pradeep


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65608/#review197263
-----------------------------------------------------------


On Feb. 12, 2018, 2:09 p.m., Pradeep Agrawal wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/65608/
> -----------------------------------------------------------
> 
> (Updated Feb. 12, 2018, 2:09 p.m.)
> 
> 
> Review request for ranger, Ankita Sinha, Don Bosco Durai, deepak sharma, Gautam Borad,
Mehul Parikh, suja s, and Velmurugan Periasamy.
> 
> 
> Bugs: RANGER-1980
>     https://issues.apache.org/jira/browse/RANGER-1980
> 
> 
> Repository: ranger
> 
> 
> Description
> -------
> 
> **Problem Statement:** Ranger Build is failing on ranger-0.7 branch.
> 
> **Proposed Solution:** It seems 0.8.2-SNAPSHOT jars have been removed from all the sub-modules
of https://repository.apache.org/content/repositories/snapshots/org/apache/atlas. However
0.8.3-SNAPSHOT jars are available and I am able to build ranger-0.7 using the 0.8.3-SNAPSHOT
jar.
> 
> 
> Diffs
> -----
> 
>   pom.xml cc09475 
> 
> 
> Diff: https://reviews.apache.org/r/65608/diff/1/
> 
> 
> Testing
> -------
> 
> Steps performed for Ranger-admin(with patch):
> 1. Created Build with patch and untar the build.
> 2. Opened install.properties and provided db configuration in install.properties
> 3. Called setup.sh
> 
> **Expected Behavior:**
> Ranger-admin installation should finish successfully.
> 
> **Actual Behavior:**
> Ranger-admin Installation finished successfully.
> 
> 
> Thanks,
> 
> Pradeep Agrawal
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message