ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ramesh Mani <rm...@hortonworks.com>
Subject Re: Moving master to Java 1.8?
Date Mon, 18 Dec 2017 18:08:23 GMT
Colm,

I having being thinking on this, when we move to Hbase 2.0 version we need
Java 1.8 for the  Ranger hbase plugin to compile.

+1 for this.

Thanks,
Ramesh

On 12/16/17, 10:18 AM, "Colm O hEigeartaigh" <coheigea@apache.org> wrote:

>Hi all,
>
>Before I fix the currently failing Hive tests with JDK 7, I'm wondering if
>it's time to move Ranger master to require Java 1.8. Apache Hadoop 3.0.0
>requires Java 1.8 - so we will have to make the switch if we want to pick
>up Hadoop 3.0.0 for Ranger 1.0.0. Apache Knox 0.14.0 is also Java 8 only,
>so we can't upgrade to that as things stand.
>
>Thoughts?
>
>Colm.
>
>
>-- 
>Colm O hEigeartaigh
>
>Talend Community Coder
>http://coders.talend.com


Mime
View raw message