qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Qpid Proton cannot connect to Azure Service Bus 'amqp:connection:framing-error'
Date Thu, 28 Feb 2019 13:05:15 GMT
On 25/02/2019 1:01 pm, Oskar Christensson wrote:
> We're trying to get a C++ connection to Azure Service Bus using AMQP with QPID proton,
and trying out the examples under qpid-proton/cpp/examples it fails.
> 
> Steps to reproduce:
> 
>    1.  Clone qpid-proton
>    2.  Follow installation and make README
>    3.  Create new Service Bus Namespace in azure
>    4.  Create new Service Bus Queue in Azure with Sessions enabled
>    5.  Create a policy with all permissions
>    6.  `./service_bus -n <namespace>.servicebus.windows.net -p <policy_name>
-k <uri_encoded_policy_key> -e <queue_name>
> 
> Expected results:
> 
> It should work according to the docs in the cpp/examples/service_bus.cpp docs
> 
> Actual results:
> 
> amqp:connection:framing-error: SASL header mismatch: Insufficient data to determine protocol
[''] (connection aborted)

I don't really know anything about servicebus. However I tried that 
example with a fake namespace and got a slightly different error. The 
error you get sounds like it is not getting the 8 byte header that it 
expects to start with. Perhaps try with different values for the policy, 
key and queue to see if that has any difference.

Cliff, do you have any suggestions? (I think this example came from you 
originally?)

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message