qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: WARNING: proton ruby package and gem name change
Date Wed, 07 Mar 2018 11:47:47 GMT
Thats a great point which I hadnt considered. I agree that if doing
it, that would make now a good time to do so.

One issue is that anyone already using it wont necessarily see the new
versions with different name, and thus the important change of
removing Messenger, since the existing named one will remain and no
longer be changed (though the text for its page should be updated to
clearly point to the newer artifact).

That said, it is a benefit in many other ways that anything just
picking up the latest version automatically isnt immediately broken
because of the Messenger change, and works with existing releases
until any transition is made to the newer bits.

Rock, hard place :)

On 6 March 2018 at 18:35, Justin Ross <justin.ross@gmail.com> wrote:
> I don't feel very strongly about doing it or not doing it.  If we are going
> to do it, however, this is good timing, since we'll be removing Messenger
> in the same release.  Users who want to carry on with the existing API
> would continue with the older releases and package name.
>
> On Fri, Mar 2, 2018 at 9:37 AM, Robbie Gemmell <robbie.gemmell@gmail.com>
> wrote:
>
>> Whilst the recommendation is clearly not what is being used, how much
>> of an issue is this? It doesnt seem to be a hard requirement for
>> example.
>>
>> I wonder if the disruption caused from changing it after ~6 years and
>> dealing with any resulting confusion actually outweighs the benefits
>> of it being as recommended.
>>
>> On 2 March 2018 at 16:18, Alan Conway <aconway@redhat.com> wrote:
>> > The proton ruby gem and package are incorrectly named according to the
>> > standard gem naming rules, see
>> > https://issues.apache.org/jira/browse/PROTON-1760 for details.
>> >
>> > The short story is we want to change the name from "qpid_proton" to
>> > "qpid-proton" for the next release (0.22, not the 0.21 release in
>> progress)
>> >
>> > The impact is that code using the package would need to change lines
>> > `require 'qpid_proton'` to `require 'qpid-proton'`. It's annoying, but it
>> > seems best to get it right as quickly as possible.
>> >
>> > The plan is be to leave the "qpid_proton" gem available, but stalled at
>> > version 0.21. Code using the "qpid_proton" gem won't break but to avail
>> of
>> > future updates you'll need to switch to using the "qpid-proton" gem
>> > instead. If you're using ruby from a downloaded source package or git
>> clone
>> > you'll need to update your code to use the 0.22 release.
>> >
>> > I'll make the change next week - I want to make it early in the release
>> > cycle so we have time to  find and iron out problems. If anyone has
>> > questions, problems or suggestions about how to make the transition
>> > smoother please respond to the list or comment on the JIRA
>> > https://issues.apache.org/jira/browse/PROTON-1760
>> >
>> > Cheers,
>> > Alan.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
>> For additional commands, e-mail: users-help@qpid.apache.org
>>
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message