qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: qpid-conf and AMQP version
Date Thu, 18 Jan 2018 10:09:31 GMT
On 18/01/18 09:38, Jan Bares, WOOD & Co. wrote:
> I installed C++ broker 1.37 and configured:
> 
> protocols=amqp1.0
> 
> but qpid-config complains:
> 
> # qpid-config exchanges
> Failed: VersionError: client: 0-10, server: 0-0
> 
> I also tried with
> 
> protocols=amqp1.0,amqp0-10
> 
> but same result, there is no fallback?
> 
> It works only when protocols are not specified. Would someone shed some light on this?

The qpid-config tool unfortunately only speaks AMQP 0-10 at present. If 
you set AMQP 1.0 to be the only protocol, it can't connect.

To specify multiple protocols, use separate protocol options. E.g. on 
command line do:

   --protocol amqp1.0 --protocols amqp0-10

and in a config file do:

protocols=amqp1.0
protocols=amqp0-10

(Not the most intuitive configuration, I accept.)

Note that these are the only two supported options, so enabling them 
both is what you get by default anyway.

The c++ client has its own option, default-protocols, and there the 
ordering matters (and it is a comma separated list), as it dictates the 
order in which the protocols are tried. The server waits for the client 
to indicate the protocol it is using then responds.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message