qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gewesp <gew...@gmail.com>
Subject New user questions: Broker/AMQP versions
Date Mon, 22 Jan 2018 14:05:33 GMT
Hi all,

I'm consulting with a company in the security business and we're evaluating
the use of QPID as a messaging platform.

Q1: Supported AMQP versions of the C++ broker (qpidd):
* According to   https://qpid.apache.org/components/cpp-broker/index.html
<https://qpid.apache.org/components/cpp-broker/index.html>   ,
it supports 0-10 and 1.0.
* According to 
https://qpid.apache.org/releases/qpid-cpp-1.37.0/cpp-broker/book/AMQP-Compatibility.html
<https://qpid.apache.org/releases/qpid-cpp-1.37.0/cpp-broker/book/AMQP-Compatibility.html>
 
,
it supports 0-9 and 0-10 .
Which one is it?

Q2: APIs:  As far as I understand, there are two C++ APIs (Messaging and
Proton).  Which one of 
these is the preferred one and will be supported in the long run?

Q3: Python3 support: AFAICS, there is Python3 support for the Proton API,
but not for Messaging (neither
is it planned?).  Can I deduce from that that the Proton API is the
preferred one?

FWIW, we're using Ubuntu 16.04 (LTS) and we'd like to go with standard
Ubuntu packages
as far as practicable.  The project requires the use of AMQP 1.0.

Thanks for any insights!

Best
--Gerhard Wesp
http://www.kisstech.ch/ <http://www.kisstech.ch/>  



--
Sent from: http://qpid.2158936.n2.nabble.com/Apache-Qpid-users-f2158936.html

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message