qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From andi welchlin <andi.welch...@gmail.com>
Subject SASL can not parse configuration file
Date Fri, 10 Nov 2017 10:31:56 GMT
Hello all,

I tried to configure SASL for Qpid C++ broker 1.36.0 but it seems like I
missed something.

What I did:
----------------

Installed Cyrus SASL.

Created a SASL database with a user "bob" using:

saslpasswd2 -f qpidd.sasldb -u QPID bob

Checked the db using sasldblistusers2 and it worked.


Configured qpidd using qpidd.conf

auth=YES
realm=QPID
sasl-config=/home/andreas/brokers/qpid/qpid-configuration



Both qpidd.conf and qpidd.sasldb are located in the configured directory
and the sasldb is readable for every user.

Then I started qpidd and it told me this:

/home/andreas/brokers/qpid/qpid-cpp-1.36.0/src/qpidd.cpp:111: Unexpected
error: SASL: failed to parse SASL configuration file in
(/home/andreas/brokers/qpid/qpid-configuration/qpid1), error: generic
failure
(/home/andreas/brokers/qpid/qpid-cpp-1.36.0/src/qpid/broker/SaslAuthenticator.cpp:181)


Looking into the code I can see that sasl_server_init failed. But I don't
get what the reason could be since I could read the db using
sasldblistusers2.


Do I have to set some environment variables?

What did I miss?

Any hints are welcome.


Cheers,
Andreas

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message