qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philipp Eib" <philipp....@greenteg.com>
Subject Proton bindings for python3
Date Thu, 14 Sep 2017 13:16:25 GMT
Hi,

what do I need to set to build the proton bindings for python3 instead of
the default python2?

 

Background:

I need Proton with SSL support. Unfortunately, the python3-qpid-proton
package for Ubuntu is not built with SSL support => I get an error
"SSLUnavailable: amqps: SSL libraries not found".

Therefore I have built proton myself. Only problem: the python2 interpreter
is used by default.

Stupidly using the generated python2 .so in python3 results in an
"ImportError: dynamic module does not define module export function
(PyInit__cproton)".

 

Thanks,

p.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message