qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakub Scholz <ja...@scholz.cz>
Subject Re: Multiple connections with ssl client auth does not work as expected
Date Mon, 21 Aug 2017 21:18:27 GMT
This is definitely not new in 1.36. I think this is present "since the
beginning". :-(

If I remember correctly the problem was that the NSS library which handles
the SSL certificates is initialised only once even when you create multiple
connections. I was quite sure this was already discussed in some issue or
on the mailing list but I have problems finding it now - I will keep
looking.

Regards
Jakub

On Mon, Aug 21, 2017 at 10:46 PM, Chris Richardson <cr@fourc.eu> wrote:

> Hi,
>
> I've encountered an issue with the C++ broker (1.36) where it appears
> that multiple connections within the same process using SSL client
> auth do not use the "ssl-cert-name" property provided when the
> connection instance is created. Rather, it appears the second
> connection will use auth details of the first connection.
>
> Is this expected behaviour?
>
> Setup to show this happening is rather involved so I've created a jira
> issue with some attached material to demonstrate the problem:
> https://issues.apache.org/jira/browse/QPID-7894.
>
> Regards
>
> --
> Chris Richardson, System Architect
> cr@fourc.eu
>
> FourC AS, Vestre Rosten 81, Trekanten, NO-7075 Tiller, Norway
> www.fourc.eu
>
> Follow us on LinkedIn, Facebook, Google+ and Twitter!
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message