qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From girish lc <girish...@gmail.com>
Subject Re: Qpid High Availability
Date Tue, 11 Jul 2017 09:04:31 GMT
Hi Alex,

Could you please share me the location from where I can download bdb je
5.0.104, as I'm not able to find.

Many thanks,

On Tue, Jul 11, 2017 at 1:40 PM, Oleksandr Rudyy <orudyy@gmail.com> wrote:

> Hi Girish,
>
> I tested HA with bdb je 5.0.73 and got the same error. It appears that je
> configuration setting "je.cleaner.adjustUtilization" was introduced in
> versions after 5.0.73. Unfortunately, the setting is hard-coded in the Qpid
> code. In order to resolve the issue you need to upgrade bdb je to 5.0.104.
>
> Kind Regards,
> Alex
>
> On 10 July 2017 at 16:50, girish lc <girish.lc@gmail.com> wrote:
>
> > Hi Alex,
> >
> > Thank you for the email,
> >
> > I'm using the below version:
> >
> > qpid-java-6.1.4
> > Berkeley DB Java Edition - 5.0.73
> >
> > Please let me know the correct combination.
> >
> > On Mon, Jul 10, 2017 at 6:54 PM, Oleksandr Rudyy <orudyy@gmail.com>
> wrote:
> >
> > > Hi Girish,
> > >
> > > What version of bdb je library are you using?
> > >
> > > 6.x versions of Qpid Broker are based on bdb je version 5.0.104 due to
> > > Oracle license change.
> > >
> > > Master and new 7.x versions of the Broker will be based new bdb je
> > versions
> > > ( 7.3.7 and above), as Oracle started to distribute je with dual
> > licenses -
> > > one of which is Apache license.
> > >
> > > I am guessing that you are trying to start 6.x version of Broker with
> bd
> > je
> > > 7.3.x.  Please, use je version 5.0.104.
> > >
> > > Kind Regards,
> > > Alex
> > >
> > >
> > > On 10 July 2017 at 14:03, Chandrashekar, Girish <
> > gchandrashekar@wabtec.com
> > > >
> > > wrote:
> > >
> > > > Hi Team,
> > > >
> > > >
> > > > Could you please help me to setup Qpid High Availability
> functionality.
> > > >
> > > >
> > > > I am referring the below link, but I am not successful to setup; in
> > fact
> > > I
> > > > got the "422 - je.cleaner.adjustUtilization is not a valid BDBJE
> > > > environment parameter" error  and also I had lost the files and
> folders
> > > > present in my C:\ after this error. I tried the same in 2 virtual
> > > machines
> > > > and also in my local machine same result 😞
> > > >
> > > >
> > > > https://qpid.apache.org/releases/qpid-java-6.1.4/java-
> > > > broker/book/Java-Broker-High-Availability-CreatingGroup.html
> > > >
> > > >
> > > > Can someone let me know the root cause and also please help me to
> setup
> > > > the High Availability functionality.
> > > >
> > > >
> > > > Regards,
> > > >
> > > > Girish LC
> > > >
> > > > 09886521716
> > > >
> > > > This email and any attachments are only for use by the intended
> > > > recipient(s) and may contain legally privileged, confidential,
> > > proprietary
> > > > or otherwise private information. Any unauthorized use, reproduction,
> > > > dissemination, distribution or other disclosure of the contents of
> this
> > > > e-mail or its attachments is strictly prohibited. If you have
> received
> > > this
> > > > email in error, please notify the sender immediately and delete the
> > > > original. Neither this information block, the typed name of the
> sender,
> > > nor
> > > > anything else in this message is intended to constitute an electronic
> > > > signature unless a specific statement to the contrary is included in
> > this
> > > > message.
> > > >
> > >
> >
> >
> >
> > --
> > Regards,
> > Girish LC
> > #09886521716
> >
>



-- 
Regards,
Girish LC
#09886521716

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message