qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: 2017-05-09 22:20:29,796 | ERROR | mix-7.0.0/deploy | BlueprintDeploymentListener | 105 - org.apache.karaf.deployer.blueprint - 4.0.8 | Unable to parse deployed file /tmp/apache-servicemix-7.0.0/deploy/qpid-routes-iv.xml org.xml.sax.SAXParseException: The reference to entity "transport.keyStorePassword" must end with the ';' delimiter. ERROR
Date Tue, 09 May 2017 22:32:29 GMT
Looks like an XML parsing error. Escaping the "&" as "&amp;" in the
URL should do the trick.

On 9 May 2017 at 23:26, jeunii <ijunaidsubhani@gmail.com> wrote:
> I am trying to setup a connection using SSL.
>
> My config initially was ::
>
>  <bean id="amqp" class="org.apache.camel.component.amqp.AMQPComponent">
>     <property name="connectionFactory">
>        <bean class="org.apache.qpid.jms.JmsConnectionFactory">
>          <property name="remoteURI"
> value="amqp://esesslx0827.ss.sw.ericsson.se:9443" />
>        </bean>
>     </property>
>   </bean>
>
> In order to secure my connection, now Im using ::
>
> <property name="remoteURI"
> value="amqps://esesslx0827.ss.sw.ericsson.se:9443?transport.keyStoreLocation=etc/qpid.jks&transport.keyStorePassword=test123"
> />
>
> As per documentation, I can add a number of parameter by seperating them
> using '&'.
>
> But I am getting the ERROR ::
>
> Unable to parse deployed file
> /tmp/apache-servicemix-7.0.0/deploy/qpid-routes-iv.xml
> org.xml.sax.SAXParseException: The reference to entity
> "transport.keyStorePassword" must end with the ';' delimiter.
>         at
> org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(Unknown
> Source)[:]
>
>
> I tried doing the following ::
>
> <property name="remoteURI"
> value="amqps://esesslx0827.ss.sw.ericsson.se:9443?transport.keyStoreLocation=etc/qpid.jks;&transport.keyStorePassword=test123;"
> />
>
> But Im getting the same ERROR. Ive tried looking at multiple forums but I do
> not see the use of ";" as a separator. Im confused as to what is the issue ?
> Do I need to update my libraries ?
>
>
>
>
>
> --
> View this message in context: http://qpid.2158936.n2.nabble.com/2017-05-09-22-20-29-796-ERROR-mix-7-0-0-deploy-BlueprintDeploymentListener-105-org-apache-karaf-deplR-tp7663005.html
> Sent from the Apache Qpid users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message