qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clemens Vasters <cleme...@microsoft.com.INVALID>
Subject AW: Reg : Issue with Windows Service Bus with AMQP and Qpid
Date Tue, 16 May 2017 20:25:45 GMT
Hello Suresh,

I can't help with the concrete issue at hand and I usually don't speak up on this list, but
before you make any major investments going down that path, be aware of Service Bus for Windows
Server going out of mainstream support by January 2018. Please review https://azure.microsoft.com/en-us/blog/collaboration-and-federation-azure-service-bus-messaging-on-premises-futures/

Apache Qpid and Apache ActiveMQ Artemis are fine on-premises brokers to look at and they speak
the right protocol.

Best Regards
Clemens Vasters
Architect - Azure Messaging
@clemensv

Von: Suresh Gade [mailto:suresh@saliense.com]
Gesendet: Dienstag, 16. Mai 2017 16:19
An: users@qpid.apache.org
Betreff: Reg : Issue with Windows Service Bus with AMQP and Qpid

Hi

I was trying to implement Windows Service Bus 1.1 with AMQP for my project, I have installed
Windows Service Bus 1.1
and created a Queue with the name test using Service Bus Explorer,
I am testing the sample Service bus functionality with the Java program attached in the email,

When I run the Java program i am getting the ConcurrentTimeOutException when creating the
producer.
I am pretty much new to the Service Bus thing and I tried to find out some solution online
but it wasn't successful.

The servicebus.properties file contains the below content
connectionfactory.SBCF = amqps://username:password@FQDN/ swebns
queue.QUEUE = swebns/test

Below is my console log

Initial setup
Creating context
Creating connection factory
Creating connection
Creating session
Creating queue
Exception creating producer
javax.jms.JMSException: java.util.concurrent.TimeoutException
      at org.apache.qpid.amqp_1_0.jms.impl.MessageProducerImpl.<init>(MessageProducerImpl.java:98)
      at org.apache.qpid.amqp_1_0.jms.impl.SessionImpl.createProducer(SessionImpl.java:390)
      at org.apache.qpid.amqp_1_0.jms.impl.SessionImpl.createProducer(SessionImpl.java:59)
      at prerna.jms.test.QpidTest.main(QpidTest.java:59)
Caused by: org.apache.qpid.amqp_1_0.client.Sender$SenderCreationException: java.util.concurrent.TimeoutException
      at org.apache.qpid.amqp_1_0.client.Sender.<init>(Sender.java:178)
      at org.apache.qpid.amqp_1_0.client.Sender.<init>(Sender.java:119)
      at org.apache.qpid.amqp_1_0.client.Sender.<init>(Sender.java:112)
      at org.apache.qpid.amqp_1_0.client.Sender.<init>(Sender.java:98)
      at org.apache.qpid.amqp_1_0.client.Sender.<init>(Sender.java:84)
      at org.apache.qpid.amqp_1_0.client.Sender.<init>(Sender.java:78)
      at org.apache.qpid.amqp_1_0.client.Session$1.<init>(Session.java:90)
      at org.apache.qpid.amqp_1_0.client.Session.createSender(Session.java:89)
      at org.apache.qpid.amqp_1_0.jms.impl.MessageProducerImpl.<init>(MessageProducerImpl.java:86)
      ... 3 more
Caused by: java.util.concurrent.TimeoutException
      at org.apache.qpid.amqp_1_0.transport.ConnectionEndpoint.waitUntil(ConnectionEndpoint.java:1232)
      at org.apache.qpid.amqp_1_0.transport.ConnectionEndpoint.waitUntil(ConnectionEndpoint.java:1214)
      at org.apache.qpid.amqp_1_0.transport.SessionEndpoint.waitUntil(SessionEndpoint.java:681)
      at org.apache.qpid.amqp_1_0.transport.LinkEndpoint.waitUntil(LinkEndpoint.java:355)
      at org.apache.qpid.amqp_1_0.client.Sender.<init>(Sender.java:167)
      ... 11 more

Any help would be greatly appreciated.

Thanks,
Suresh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message