qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: Usage of qpid in JavaEE Websphere Liberty with AMQP 1.0
Date Fri, 28 Apr 2017 13:00:25 GMT
On 27 April 2017 at 13:19, Jakoby Thorsten
<Thorsten.Jakoby@novatec-gmbh.de> wrote:
> Hello everyone,
>
>
> I am trying to use qpid in order to communicate with a queue at Azure Service Bus.
>
> In a very basic application that works fine.
>
> But in the target project the environment as a IBM WebSphere Liberty Profile application
which is using JMS.
>
> I tried to configure qpid-rar as resource adapter but it is not able to connect with
Azure SB.
>
> Instead of connecting it is complaining about "Not a AMQP URL".
>
> It seems that the qpid-rar is not AMQP 1.0 compatible.
>

That's correct, that was inherently tied to the AMQP 0-x JMS client.
It won't actually be present beyond the 6.1.x line of releases:
https://issues.apache.org/jira/browse/QPID-7716

> Can somebody please give me a hint how I could use qpid for connecting Azure Service
Bus in a Java EE application server ?
>

The AMQP 1.0 JMS client does not have a specific JCA resource adapter
of its own, so you would either have to try some of the attempts at
generic ones (not something I have tried), or perhaps simply invoke
its use directly as you might outwith Java EE.

>
> Thank you in advance.
>
>
> Kind Regards
>
> Thorsten Jakoby?
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message