qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Ross <tr...@redhat.com>
Subject Re: Configuring addresses starting with '/' on qpid-dispatch router 0.7.0
Date Wed, 29 Mar 2017 09:48:23 GMT


On 03/08/2017 02:33 PM, Alan Conway wrote:
> On Fri, 2017-03-03 at 09:58 +0000, Antoine Chevin wrote:
>> Hello,
>>
>> Do you have an idea on the below behavior?
>
> This is related to early drafts of the AMQP addressing specification,
> but those are out of date now and the specification is still not
> released.
>
> Given that, I think this behavior is probably not helpful - dispatch
> should accept address exactly as provided by the user and do no
> modification. I'm not 100% sure if that would cause any internal
> problems for the router, if not we should raise an issue.
>
> Ted do you have any thoughts?

Dispatch normalizes addresses to make sure that various "equivalent" 
forms are hashed to the same entry in the address table.

As Alan pointed out, we use a URL-like address format per early drafts 
of the addressing specification.  As such, the leading slash is removed 
from the normalized address.

>
>>
>> Thank you,
>> Regards,
>> Antoine
>>
>> -----Original Message-----
>> From: Antoine Chevin [mailto:antoine.chevin@gmail.com]
>> Sent: jeudi 2 mars 2017 10:43
>> To: users@qpid.apache.org
>> Subject: Configuring addresses starting with '/' on qpid-dispatch
>> router
>> 0.7.0
>>
>> Hello,
>>
>> I tried to configure addresses starting with a '/' but using qdstat I
>> see
>> that this '/' is removed. Is it expected?
>> I noticed the same behavior with autolinks.
>>
>> Thank you,
>> Regards,
>> Antoine
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message