qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gregory Simpson <gbsim...@aggies.ncat.edu>
Subject Re: qpid-route version error
Date Thu, 19 Jan 2017 20:23:03 GMT
So currently I have 2 VMs and on one of them the the following command
works:
qpid-route map localhost:5672

On the working VM I turned on the extra logging by using the -t option and
seen that it is connecting to the broker.


On the non working VM, when I run the the same commands it is failing with
the VersionError exception that I shown before. I believe it is because for
some reason it is not connecting to the broker. I say this because with the
extra logging turned on the broker does not respond when I run the
qpid-route command. I have tracked the raised exception down to the
"delegates.py" script lines 176-179 which are the following lines of code:

magic, _, _, major, minor = self.connection.read_header()
    if not (magic == "AMQP" and major == cli_major and minor == cli_minor):
      raise VersionError("client: %s-%s, server: %s-%s" %
                         (cli_major, cli_minor, major, minor))


On Thu, Jan 19, 2017 at 2:18 AM, Gordon Sim <gsim@redhat.com> wrote:

> On 18/01/17 23:47, Gregory Simpson wrote:
>
>> qpid-cpp version 0.34
>>
>> If it doesn't is there a way around or will I have to upgrade to 1.36?
>>
>
> qpid-cpp supports 0-10 by default (i.e. unless it is explicitly turned
> off). Are you sure it is the qpid-cpp broker you are connecting to? Is
> there anything on the broker log? Can you turn on extra logging
> temporarily? Or perhaps get a wireshark trace if thats easier?
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>
>


-- 
Gregory Simpson
BS, Computer Engineering
Masters Student, Computer Science
North Carolina Agricultural and Technical State University

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message