qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bee <nbe...@hotmail.com>
Subject qpid-0.20 Execution exception: resource-locked
Date Mon, 05 Dec 2016 19:41:58 GMT
Hello, I'm quite new here.  Hopefully, I can get some help for qpid-0.20 I'm using at work.

A few times now, I get this error:
[Protocol] error Execution exception: resource-locked: Cannot grant exclusive access to queue
  (qpid/broker/SessionAdapter.cpp:324)

Please correct me, but my understanding is this is a race condition where connection unexpectedly
close, broker-client tries to re-initiate the session, but the exclusive queue has not been
freed yet.
When this happens, client or broker (I'm not sure) stops trying to establish the session again.

My question is, how can I ensure the session can re-establish again by itself.  And, how can
I reproduce this issue.  I've tried iptables, it seems to reconnect as it's supposed to. 
I've tried qpid-config del queue, I get msg that queue is deleted, but not the same error
msg.

I'm using these options for broker
reconnect: true
heartbeat: 1
tcp_nodelay: true
reconnect_timeout: 2.0
reconnect_interval_min: 0.1
reconnect_interval_max: 2.0


Any insights will be very appreciated.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message